[PVE-User] Backup fail with 'no disk', but manually works!

Marco Gaiarin gaio at sv.lnf.it
Mon Feb 11 11:03:48 CET 2019


I've setup a script, for a bacula backup setup, that weekly dump VMs/LXCs,
cleanup the backup dir anche then put VMs on tape.

A backup of a VM fail, every week, with:

 108: 2019-02-08 20:19:04 INFO: Starting Backup of VM 108 (qemu)
 108: 2019-02-08 20:19:04 INFO: status = running
 108: 2019-02-08 20:19:28 INFO: update VM 108: -lock backup
 108: 2019-02-08 20:19:28 INFO: VM Name: dixie
 108: 2019-02-08 20:19:28 INFO: include disk 'virtio0' 'VM0:vm-108-disk-1' 100G
 108: 2019-02-08 20:20:12 ERROR: Backup of VM 108 failed - no such volume 'VM0:vm-108-disk-1'

note that:

a) disk exist; disk reside on the same SAN with all my other VMs, that
 the same script backup without trouble.

b) i've also a ''normal'' PVE backup tasks that do a dump of that VMs
 every day, and works.

c) if i try a manual backup (from PVE web interface), work.


The script do simply:
	vzdump 108 -storage Backup -maxfiles 1 -remove -compress lzo -mode snapshot -quiet -mailto ced -mailnotification failure

-- 
dott. Marco Gaiarin				        GNUPG Key ID: 240A3D66
  Associazione ``La Nostra Famiglia''          http://www.lanostrafamiglia.it/
  Polo FVG   -   Via della Bontà, 7 - 33078   -   San Vito al Tagliamento (PN)
  marco.gaiarin(at)lanostrafamiglia.it   t +39-0434-842711   f +39-0434-842797

		Dona il 5 PER MILLE a LA NOSTRA FAMIGLIA!
      http://www.lanostrafamiglia.it/index.php/it/sostienici/5x1000
	(cf 00307430132, categoria ONLUS oppure RICERCA SANITARIA)


More information about the pve-user mailing list