[PVE-User] Request to update wiki, risk of dataloss

Mark Schouten mark at tuxis.nl
Fri Apr 12 16:41:55 CEST 2019


Hi,

I'm in the process of upgrading some older 4.x clusters with Ceph to current versions. All goes well, but we hit a bug that is understandable, but undocumented. To prevent others from hitting it, I think it would be wise to document to issue.

It is when you already upgraded Ceph to Luminous and not yet Proxmox to 5.x. Resizing a disk makes Proxmox request the current disk size. Because Luminous says 'GiB' or 'MiB' and older versions say 'GB' or 'MB', $size = 0+$increaseresizesize. A customer of mine resized their disk from 50GB to 20GB because of this issue.

So maybe a warning on https://pve.proxmox.com/wiki/Ceph_Jewel_to_Luminous and/or https://pve.proxmox.com/wiki/Upgrade_from_4.x_to_5.0 is possible?

--
Mark Schouten <mark at tuxis.nl>
Tuxis, Ede, https://www.tuxis.nl
T: +31 318 200208 
 



More information about the pve-user mailing list