[PVE-User] HA Failover if shared storage fails on one Node

Martin Holub martin at holub.co.at
Wed Oct 17 13:26:57 CEST 2018


Hi,

In my specific Test Case i was simulating that only one out of 6 Nodes
is losing connectivity to the Shared Storage. So the other 5 could still
access the Data. In my Opinion Proxmox should be, somehow, able to
detect that and fence that Node, causing a migration (depending on the
HA Configuration of course) to the other Nodes.

Best,
Martin

On 10/17/18 1:22 PM, Gilberto Nunes wrote:
> Perhaps I wasn't able to understand you issue...
> But if a storage crash, no way to migrate from a node to other, since
> Proxmox can not found the VM image... 
> Sorry if I don't see what happen cleary.
>
> ---
> Gilberto Nunes Ferreira
>
> (47) 3025-5907
> (47) 99676-7530 - Whatsapp / Telegram
>
> Skype: gilberto.nunes36
>
>
>
>
>
> Em qua, 17 de out de 2018 às 08:19, Martin Holub <martin at holub.co.at
> <mailto:martin at holub.co.at>> escreveu:
>
>     On 10/17/18 1:11 PM, Gilberto Nunes wrote:
>     > Hi
>     >
>     > How about Node priority?
>     > Look section 14.5.2 in this doc
>     >
>     >
>     https://pve.proxmox.com/pve-docs/pve-admin-guide.html#_configuration_10
>     > ---
>     > Gilberto Nunes Ferreira
>     >
>     > (47) 3025-5907
>     > (47) 99676-7530 - Whatsapp / Telegram
>     >
>     > Skype: gilberto.nunes36
>     >
>     >
>     >
>     >
>     >
>     > Em qua, 17 de out de 2018 às 08:05, Martin Holub
>     <martin at holub.co.at <mailto:martin at holub.co.at>>
>     > escreveu:
>     >
>     >> Hi,
>     >>
>     >> I am currently testing the HA features on a 6 Node Cluster and
>     a NetAPP
>     >> Storage with iSCSI and multipath configured on all Nodes. I now
>     tried
>     >> what happens if, for any reason, booth Links fail (by shutting
>     down the
>     >> Interfaces on one Blade). Unfortunately, altough i had
>     configured HA for
>     >> my Test VM, Proxmox seems to not recognize the Storage outtage and
>     >> therefore did not migrate the VM to a different blade or
>     removed that
>     >> Node from the Cluster (either by resetting it or fencing it somehow
>     >> else). Any hints on how to get that solved?
>     >>
>     >> Thanks,
>     >> Martin
>     >>
>
>     Not shure if i understood what you mean with that reference, but since
>     Proxmox does not detect that the Storage is unreachable on that
>     specific
>     Cluster Node, how are HA Groups supposed to work around this?
>
>     Best,
>     Martin
>




More information about the pve-user mailing list