[PVE-User] dual port cross over cable bonding

Adam Weremczuk adamw at matrixscience.com
Fri Oct 5 15:40:47 CEST 2018


Hello,

I have 2 servers running Proxmox 5.2.

I've connected Ethernet ports between them with a pair of cross over cables.

When only 1 port on each and 1 cable are used connectivity looks fine 
with the following config:

-------------------------------------------------------

auto ens1f0
iface ens1f0 inet static
     address 192.168.200.1(2)
     netmask 255.255.255.252

-------------------------------------------------------

Then I connected 2 cables and attempted link aggregation:

-------------------------------------------------------

iface ens1f0 inet manual

iface ens1f1 inet manual

auto bond1
iface bond1 inet static
     slaves ens1f0 ens1f1
     address 192.168.200.1
     netmask 255.255.255.252
     bond_miimon 100
#    bond_mode 802.3ad
     bond_mode balance-rr
     bond_xmit_hash_policy layer3+4

-------------------------------------------------------

Tried both 802.3ad and balance-rr modes.

AFAIK only these 2 provide link aggregation.

Ethtool appears to be happy:

ethtool bond1
Settings for bond1:
     Supported ports: [ ]
     Supported link modes:   Not reported
     Supported pause frame use: No
     Supports auto-negotiation: No
     Advertised link modes:  Not reported
     Advertised pause frame use: No
     Advertised auto-negotiation: No
     Speed: 2000Mb/s
     Duplex: Full
     Port: Other
     PHYAD: 0
     Transceiver: internal
     Auto-negotiation: off
     Link detected: yes

Unfortunately in either mode cross pinging fails with "Destination Host 
Unreachable".

Own interfaces ping ok.

The same configuration works fine against managed switch ports (LACP/LAG).

So my question is why this is not working and whether it's possible at all?

Regards,
Adam



More information about the pve-user mailing list