[PVE-User] nfs volume hangs during disk clone

Daniele Melosi ml at melosi.it
Fri Mar 16 12:15:47 CET 2018


Hi all,

i use proxmox with NFS backend for disks (with a 10G network) and i've a
strange problem:

during an image clone (this is the command):

/usr/bin/qemu-img convert -p -n -f raw -O raw
/mnt/pve/pve07/images/999/vm-999-disk-1.raw
zeroinit:/mnt/pve/pve07/images/998/vm-998-disk-1.raw

the nfs volume stop responding (df on filesystem hangs and clone process
stops and timeout after some minutes).

This is my configuration:
root at kvm50:~# pveversion --verbose
proxmox-ve: 5.1-32 (running kernel: 4.13.13-2-pve)
pve-manager: 5.1-43 (running version: 5.1-43/bdb08029)
pve-kernel-4.13.13-2-pve: 4.13.13-33
libpve-http-server-perl: 2.0-8
lvm2: 2.02.168-pve6
corosync: 2.4.2-pve3
libqb0: 1.0.1-1
pve-cluster: 5.0-19
qemu-server: 5.0-20
pve-firmware: 2.0-3
libpve-common-perl: 5.0-25
libpve-guest-common-perl: 2.0-14
libpve-access-control: 5.0-7
libpve-storage-perl: 5.0-17
pve-libspice-server1: 0.12.8-3
vncterm: 1.5-3
pve-docs: 5.1-16
pve-qemu-kvm: 2.9.1-6
pve-container: 2.0-18
pve-firewall: 3.0-5
pve-ha-manager: 2.0-4
ksm-control-daemon: 1.2-2
glusterfs-client: 3.8.8-1
lxc-pve: 2.1.1-2
lxcfs: 2.0.8-1
criu: 2.11.1-1~bpo90
novnc-pve: 0.6-4
smartmontools: 6.5+svn4324-1
zfsutils-linux: 0.7.4-pve2~bpo9
root at kvm50:~# dpkg -S /usr/bin/qemu-img
pve-qemu-kvm: /usr/bin/qemu-img

If i downgrade the kernel version to
pve-kernel-4.10.15-1-pve             4.10.15-15

the problem didn't append.

Any hits ?

Regards

-- 
Daniele Melosi


More information about the pve-user mailing list