[PVE-User] With cloud-init some bug?

lyt_yudi lyt_yudi at icloud.com
Sat Mar 24 02:03:50 CET 2018

> 在 2018年3月23日,下午6:39,Wolfgang Bumiller <w.bumiller at proxmox.com> 写道:
>>>> 在 2018年3月23日,下午5:00,lyt_yudi <lyt_yudi at icloud.com <mailto:lyt_yudi at icloud.com>> 写道:
>>>> But, the cipassword for centos user is still not set!
>>> Sorry , my fault! The cipassword can set! It’s work with cloud-init-18.1!
>> I just tried a fresh centos 7 installation. Curiously the password did
>> end up in /etc/shadow but didn't work.
> Right, that version of cloud-init doesn't support pre-hashed passwords,
> so you need to manually add the plaintext password to the vm config.
> Setting it over the API doesn't support plaintext passwords.
> How did you install the newer cloud-init versions btw.?

Use this: 
https://copr-be.cloud.fedoraproject.org/results/%40cloud-init/cloud-init-dev/epel-7-x86_64/00731396-cloud-init/cloud-init-18.1+28.gd29eeccd-1.el7.centos.noarch.rpm <https://copr-be.cloud.fedoraproject.org/results/@cloud-init/cloud-init-dev/epel-7-x86_64/00731396-cloud-init/cloud-init-18.1+28.gd29eeccd-1.el7.centos.noarch.rpm>

More information about the pve-user mailing list