[PVE-User] ZFS, grub cannot load second stage...

Marco Gaiarin gaio at sv.lnf.it
Thu Jul 19 18:34:59 CEST 2018


I've installed a little server vith PVE 5.2, using ZFS, as just done
before.
The only differences is that server have a raid-1 zpool with 4 disks (2
1TB and 2 4TB disks) all in a single 5TB rpool.
The server have a plain AHCI controller, no RAID hardware.

After configuring the server, configuring some VM/LXC inside, probably
a user inadvertitely powered off it.


The server never gone back, and print in console:

 error: no such device: aeXXXXX.
 error: unknown filesystem.
 Entering rescue mode...
 grub rescue>

in rescue mode, i can 'ls' all the disks and seems OK (number of disks
and partition match), but i cannot 'ls' inside (filesystem not found or
similar error).


I've googled and found:

	https://forum.proxmox.com/threads/crashes-with-zfs-root-and-stuck-on-grub-rescue-prompt.34172/

and i was able to run the install CD (rescue mode does nothing, say
there's no rpool) and with:

	zpool import -f -d /dev/ -R /mnt rpool

i've mounted the pool, chmod-ed on it and tried to reinstall grub and
rebuild grub confing and initrd. Data seems OK.

But after a reboot, throw the same error.


How can fix that?


The hex code in 'error: no such device: aeXXXXX.' is relative to the
'ROOT' zfs volume? How can i determine if match correctly?


Please, help me. Thanks.

-- 
dott. Marco Gaiarin				        GNUPG Key ID: 240A3D66
  Associazione ``La Nostra Famiglia''          http://www.lanostrafamiglia.it/
  Polo FVG   -   Via della Bontà, 7 - 33078   -   San Vito al Tagliamento (PN)
  marco.gaiarin(at)lanostrafamiglia.it   t +39-0434-842711   f +39-0434-842797

		Dona il 5 PER MILLE a LA NOSTRA FAMIGLIA!
      http://www.lanostrafamiglia.it/index.php/it/sostienici/5x1000
	(cf 00307430132, categoria ONLUS oppure RICERCA SANITARIA)


More information about the pve-user mailing list