[PVE-User] zfs: cannot import rpool after reboot

Dreyer, Jan, SCM-IT Jan.Dreyer at arvato.com
Tue Jul 10 09:15:00 CEST 2018


Hi,

after upgrading my Debian (and proxmox) to stretch (PVE 5.2), I got into trouble when rebooting my servers. It’s similar to https://forum.proxmox.com/threads/zfs-cannot-import-rpool-after-reboot.37611/page-2 <https://forum.proxmox.com/threads/zfs-cannot-import-rpool-after-reboot.37611/page-2> beside that a manual import does _not_ work.
When booting with the old kernel (4.4.128-1-pve) the machine comes up, but has no access to it’s (zfs-based) swap device.
I already tried to boot from the most recent 4.10, which seems to hang in a CPU-stalled loop for > 5 minutes.
„zdb" shows me the configured pools, so basically they are available.
As a workaround I set the 4.4-kernel as default for booting, but of course I want to upgrade. Does anyone has a hint on how to do it?

Regards
—
Jan Dreyer
IT Administrator — Operations — A-SCM-IT IOX Expert
This email may contain confidential and/or privileged information. If you are not the intended recipient (or have received this email in error) please notify the sender immediately and destroy this email. Any unauthorized copying, disclosure or distribution of the information in this email is strictly forbidden.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: Message signed with OpenPGP
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20180710/9caf82d4/attachment.sig>


More information about the pve-user mailing list