[PVE-User] Cluster issue!

Gilberto Nunes gilberto.nunes32 at gmail.com
Wed Jan 31 12:46:37 CET 2018


>> But, we could add a 'unicast' flag to 'pvecm create' and 'pvecm add'
>>so that an admin can set just this when needed, no manual editing needed.

Oh! This sounds great!
It's seem to me, based on your explanation, that pvecm always expect a
multicast envirolment, right?
But I thing if pvecm could give multiple choise for the admin to set
whatever they want, it wiil be perfect!
Thanks a lot

---
Gilberto Nunes Ferreira

(47) 3025-5907
(47) 99676-7530 - Whatsapp / Telegram

Skype: gilberto.nunes36




2018-01-31 9:36 GMT-02:00 Thomas Lamprecht <t.lamprecht at proxmox.com>:

> Hi,
>
> On 1/31/18 11:50 AM, Gilberto Nunes wrote:
> > Hi Ian
> >
> > In my case, I am just installed to make some tests, so I have installed
> it
> > inside other proxmox, you know? Nested Virt.
> > So I guess this is the cause, 'cause in this scenario, there's no way to
> > use multcast, or there'is??
> >
>
> For sure, I have multiple nested cluster (PVE in PVE) using multicast
> just fine.
>
> We cannot autodetect if unicast is needed on join or create,
> as testing this requires the knowledge about all other node
> members. There are no other members on create and we do not know
> of the other members yet on join.
> A good working detection (i.e. virtually no false positive) needs
> also > 5 minutes time, not ideal either.
>
> But, we could add a 'unicast' flag to 'pvecm create' and 'pvecm add'
> so that an admin can set just this when needed, no manual editing needed.
>
> cheers,
> Thomas
>
>


More information about the pve-user mailing list