[PVE-User] Cluster issue!

Gilberto Nunes gilberto.nunes32 at gmail.com
Tue Jan 30 18:39:31 CET 2018


Hi

I have a fresh instalation of Proxmox 5.1.
In the /etc/hosts I have:

127.0.0.1 localhost.localdomain localhost
10.10.10.210 pve01.domain.com pve01 pvelocalhost
10.10.10.220 pve02.domain.com pve02

in both sides, pve01 and pve02

I form the cluster with the command pvecm create HOMECLUSTER
I ssh to pve02 and do pvecm add pve01.
The cluster are formed as expected, but after 2 minutes, I get this error
in /var/log/syslog:

Jan 30 15:23:04 pve01 corosync[1482]: error   [TOTEM ] FAILED TO RECEIVE
Jan 30 15:23:04 pve01 corosync[1482]:  [TOTEM ] FAILED TO RECEIVE
Jan 30 15:23:05 pve01 corosync[1482]: notice  [TOTEM ] A new membership (
10.10.10.210:12) was formed. Members left: 2
Jan 30 15:23:05 pve01 corosync[1482]: notice  [TOTEM ] Failed to receive
the leave message. failed: 2
Jan 30 15:23:05 pve01 corosync[1482]:  [TOTEM ] A new membership (
10.10.10.210:12) was formed. Members left: 2
Jan 30 15:23:05 pve01 corosync[1482]:  [TOTEM ] Failed to receive the leave
message. failed: 2

So, I stop the cluster ( systemctl stop pve-cluster;systemctl stop
corosync) and start pmxcfs -l (localy).
I saw that in /etc/pve/corosync.conf file, the statement line:

    bindnetaddr: 10.10.10.210

So after I change this line to this:

    bindnetaddr: 10.10.10.0

and restart both nodes, the cluster back to normality.

This second line wouldn't add but pvecm script?
Why I need to change it to the network address by myself and not pvecm
script do this automaticaly??

I cannot understand!

Any advice?

Thanks a lot.





---
Gilberto Nunes Ferreira

(47) 3025-5907
(47) 99676-7530 - Whatsapp / Telegram

Skype: gilberto.nunes36


More information about the pve-user mailing list