[PVE-User] Multipath with fiber channel

Jorge Visentini jorgevisentini at gmail.com
Fri Jan 12 20:30:32 CET 2018


Hi everyone!

Sorry my english.

I'm having problem with multipath.

When I use a considerable IO, the following messages appear:

Jan 12 16:05:02 pve02 kernel: multipath_clone_and_map: 21 callbacks
suppressed
Jan 12 16:05:02 pve02 kernel: device-mapper: multipath: blk_get_request()
returned -12 - requeuing
Jan 12 16:05:02 pve02 kernel: device-mapper: multipath: blk_get_request()
returned -12 - requeuing
Jan 12 16:05:02 pve02 kernel: device-mapper: multipath: blk_get_request()
returned -12 - requeuing
Jan 12 16:05:02 pve02 kernel: device-mapper: multipath: blk_get_request()
returned -12 - requeuing
Jan 12 16:05:02 pve02 kernel: device-mapper: multipath: blk_get_request()
returned -12 - requeuing
Jan 12 16:05:02 pve02 kernel: device-mapper: multipath: blk_get_request()
returned -12 - requeuing
Jan 12 16:05:02 pve02 kernel: device-mapper: multipath: blk_get_request()
returned -12 - requeuing
Jan 12 16:05:02 pve02 kernel: device-mapper: multipath: blk_get_request()
returned -12 - requeuing
Jan 12 16:05:02 pve02 kernel: device-mapper: multipath: blk_get_request()
returned -12 - requeuing
Jan 12 16:05:02 pve02 kernel: device-mapper: multipath: blk_get_request()
returned -12 - requeuing
Jan 12 16:05:07 pve02 kernel: multipath_clone_and_map: 7309 callbacks
suppressed
Jan 12 16:05:07 pve02 kernel: device-mapper: multipath: blk_get_request()
returned -12 - requeuing
Jan 12 16:05:07 pve02 kernel: device-mapper: multipath: blk_get_request()
returned -12 - requeuing
Jan 12 16:05:07 pve02 kernel: device-mapper: multipath: blk_get_request()
returned -12 - requeuing
Jan 12 16:05:07 pve02 kernel: device-mapper: multipath: blk_get_request()
returned -12 - requeuing
Jan 12 16:05:07 pve02 kernel: device-mapper: multipath: blk_get_request()
returned -12 - requeuing



I already changed the multipath configuration, and it still did not work.
Has anyone ever had this problem?

My multipath configuration:

root at pve02:~# cat /etc/multipath.conf
devices {
        device {
                vendor "IFT"
                path_grouping_policy group_by_prio
                getuid_callout "/lib/udev/scsi_id --whitelisted
--device=/dev/%n"
                path_checker readsector0
                path_selector "round-robin 0"
                hardware_handler "0"
                failback 15
                rr_weight uniform
                no_path_retry 12
                prio alua
        }
}

blacklist {
        device {
                vendor "LSI"
        }
}


I am using version 5.1-41 of the PVE configured with Infortrend Storage via
Fiber Channel.

Thank you for all!

-- 
Att,
Jorge Visentini
+55 55 98432-9868


More information about the pve-user mailing list