[PVE-User] PVE 5.1 - Intel <-> AMD migration crash with Debian 9

Eneko Lacunza elacunza at binovo.es
Wed Feb 7 16:22:17 CET 2018


Hi Harald,

Thanks for your feedback.

El 07/02/18 a las 15:32, Harald Leithner escribió:
> we have the same problem with Debian 9 VMs, Debian 8 VMs migration is 
> fine.
>
> After testing with only 1 core, as you suggested, migration works good.
> We also upgraded to the latest Debian Kernel, I think it's 4.14.7, 
> with this version it seams to migrate stable between amd Opteron and 
> Intel Broadwell.
I just upgraded to latest kernel in stretch-backports, 4.14.13-1~bpo9+1, 
and it has crashed again; so doesn't seem to have fixed our problem. I 
tried twice just in case; near instant crashes both times ;)

We have seen the problem also with Ubuntu 14.04 kernel 3.16.0-30-generic...

Cheers
Eneko
>
> bye
>
> Harald
>
> Am 07.02.2018 um 09:33 schrieb Eneko Lacunza:
>>
>> https://bugzilla.proxmox.com/show_bug.cgi?id=1660
>>
>> El 07/02/18 a las 09:22, Eneko Lacunza escribió:
>>> Hi,
>>>
>>> I finally reproduced the problem with a Ubuntu 14.04.2 LTS VM, so 
>>> not a Debian 9-only problem.
>>>
>>> Is there anything I to report this bug to Proxmox/upstream?
>>>
>>> El 06/02/18 a las 12:07, Eneko Lacunza escribió:
>>>> Hi all,
>>>>
>>>> El 02/02/18 a las 13:21, Eneko Lacunza escribió:
>>>>>
>>>>>>> Eneko Lacunza <elacunza at binovo.es> hat am 2. Februar 2018 um 
>>>>>>> 10:14 geschrieben:
>>>>>>> proxmox-ve: 5.1-35 (running kernel: 4.13.13-4-pve)
>>>>>> This kernel produced a lot of crashes (especially on windows), 
>>>>>> even without any migrations.
>>>>>>
>>>>>> Please retest with latest kernel.
>>>>> Just updated the cluster:
>>>>> # pveversion -v
>>>>> proxmox-ve: 5.1-38 (running kernel: 4.13.13-5-pve)
>>>> [...]
>>>>> The reported VM has migrated well for now, but I have seen a 
>>>>> similar crash with another two Debian 9 VMs this time. Other VMs 
>>>>> and SO/distros continue to work well, maybe there's a problem in 
>>>>> guest kernel. I continue to get crashes after Intel<>AMD 
>>>>> migrations, Intel<->Intel migrations work without issue (done 
>>>>> ten's of them during cluster upgrade).
>>>>>
>>>> Seems that only Debian 9 VMs with more than 1 cores are affected by 
>>>> this problem. All 3 VMs had 2 or 4 cores. I changed the original 
>>>> reported VM to 1 core, and seems not to crash now. NUMA is not 
>>>> enabled.
>>>>
>>>> I tried with previous Debian kernel (VMs are running now 
>>>> 4.9.0-5-amd64, previous is 4.9.0-4-amd64); and it crashes too.
>>>>
>>>> I tried with a Ubuntu 14.04.02 LTS with 2 cores, but I'm unable to 
>>>> reproduce the problem. Windows VMs also really seem unaffected.
>>>>
>>>> Shall I report this to Debian kernel team?
>>>>
>>>> Thanks a lot
>>>> Eneko
>>>>
>>>
>>
>

-- 
Zuzendari Teknikoa / Director Técnico
Binovo IT Human Project, S.L.
Telf. 943569206
Astigarraga bidea 2, 2º izq. oficina 11; 20180 Oiartzun (Gipuzkoa)
www.binovo.es



More information about the pve-user mailing list