[PVE-User] WebUI Asking login when changing node

Yannis Milios yannis.milios at gmail.com
Sat Dec 29 15:13:10 CET 2018


A few things I would try are ...

- Clear browser cache.
- Check if installed package versions are the same on *all* nodes
(pveversion -v).
- Restart pveproxy service on pve2 (or any other related service).
- Check the logs of pve2 when you try accessing it for any clues.

Do you get the same problem when accessing pve2 from pve3?

Yannis


On Sat, 29 Dec 2018 at 11:32, Nicola Ferrari (#554252) <nick-liste at posteo.eu>
wrote:

> Hi list!
>
> We're experiencing a little problem on a 3 machines cluster, let's call
> them pve1, pve2, pve3
>
> accessing webui pointing to https://pve1:8006 shows entire cluster
> correctly..
> ssh on all nodes is working and accessing other nodes doesn't require
> credentials (so keys are working)
> live migration between nodes is working... but...
>
> clicking on pve2 (or any resource on pve2) if viewing interface at
> pve1's ip keeps asking to re-enter login credentials!
> so to manage pve2 resources we need to point to pve2's ip and everything
> is fine (but obviewsly clicking on pve1 from pve2 re-asks login...)
>
> This happens after cluster upgrade from pve4 to pve5 in last july..
>
> pveversion -v output:
> proxmox-ve: 5.2-2 (running kernel: 4.15.18-1-pve)
> pve-manager: 5.2-6 (running version: 5.2-6/bcd5f008)
> pve-kernel-4.15: 5.2-4
> pve-kernel-4.15.18-1-pve: 4.15.18-17
> pve-kernel-4.13.16-2-pve: 4.13.16-48
> corosync: 2.4.2-pve5
> criu: 2.11.1-1~bpo90
> glusterfs-client: 3.8.8-1
> ksm-control-daemon: 1.2-2
> libjs-extjs: 6.0.1-2
> libpve-access-control: 5.0-8
> libpve-apiclient-perl: 2.0-5
> libpve-common-perl: 5.0-37
> libpve-guest-common-perl: 2.0-17
> libpve-http-server-perl: 2.0-9
> libpve-storage-perl: 5.0-24
> libqb0: 1.0.1-1
> lvm2: 2.02.168-pve6
> lxc-pve: 3.0.0-3
> lxcfs: 3.0.0-1
> novnc-pve: 1.0.0-2
> proxmox-widget-toolkit: 1.0-19
> pve-cluster: 5.0-29
> pve-container: 2.0-24
> pve-docs: 5.2-5
> pve-firewall: 3.0-13
> pve-firmware: 2.0-5
> pve-ha-manager: 2.0-5
> pve-i18n: 1.0-6
> pve-libspice-server1: 0.12.8-3
> pve-qemu-kvm: 2.11.2-1
> pve-xtermjs: 1.0-5
> qemu-server: 5.0-30
> smartmontools: 6.5+svn4324-1
> spiceterm: 3.0-5
> vncterm: 1.5-3
>
>
> Any hints from you experts? :)
> Thanks to everybody!
>
> Nick
>
>
> --
> +---------------------+
> | Linux User  #554252 |
> +---------------------+
>
> _______________________________________________
> pve-user mailing list
> pve-user at pve.proxmox.com
> https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
>
-- 
Sent from Gmail Mobile


More information about the pve-user mailing list