[PVE-User] windows 2008 enterprise with uefi

Christian Meiring christian at meiring.de
Tue Aug 28 16:34:06 CEST 2018


Am Dienstag, 28. August 2018, 11:20:22 CEST schrieb lists:
> If, during windows iso boot, I press F8 for advanced options, and I 
> select safe mode, I can the last line displayed is:
> 
> Loaded: \windows\system32\drivers\disk.sys
> 
> Then progress stops.

i do not know the whole magic, but on older windows installations (xp, 2k3, maybe w7) you must apply a MergeIDE.reg entry. 
This must be done inside running physical machine, before the backup.

> 
> I changed the VM disk config from IDE to SCSI, to see if that made a 
> difference. But alas, no further progress... :-(
> 
> MJ
> 
> 
> 
> On 28-8-2018 10:59, lists wrote:
> > Here is the VM config:
> > 
> >> balloon: 0
> >> bios: ovmf
> >> boot: dcn
> >> bootdisk: ide0
> >> cores: 2
> >> efidisk0: local-btrfs:107/vm-107-disk-2.qcow2,size=128K
> >> ide0: local-btrfs:107/vm-107-disk-1.qcow2,size=233G
> >> ide2: local-btrfs:iso/win2008_enterprise_x64.iso,media=cdrom
> >> memory: 8192
> >> name: win8-uefi
> >> net0: e1000=BA:7F:7B:91:9B:1C,bridge=vmbr0
> >> numa: 0
> >> ostype: win8
> >> scsihw: virtio-scsi-pci
> >> smbios1: uuid=626ef0a6-0161-492f-80b7-fbc437c4cdb2
> >> sockets: 2
> > 
> > OS Type set to Windows 8.x/2012/2012r2
> > KVM Hardware virtualization: yes
> > Freez cpu at startup: no
> > Protection: no
> > Qemu Agent: no
> > Bus: IDE
> > 
> > Anything else I need to tell?
> > 
> > MJ
> > 
> > On 28-8-2018 10:54, Lindsay Mathieson wrote:
> >> What virtual hardware are you giving it? bus, disk etc.
> >>
> >> On 28/08/2018 6:06 PM, lists wrote:
> >>> Hi,
> >>>
> >>> I am trying to move a physical windows 2008 enterprise uefi 
> >>> installation (Version 6.0.6002 Service Pack 2 Build 6002) into 
> >>> proxmox, and I'm getting nowhere.
> >>>
> >>> Tried all kinds of approaches, and this was my latest attempt:
> >>>
> >>> Creating a full system backup using windows backup, and then boot the 
> >>> windows install iso in proxmox, to perform a system restore from this 
> >>> backup into proxmox.
> >>>
> >>> But as soon as I enable uefi in my proxmox VM config, the windows iso 
> >>> no longer boots. However, the physical server IS this same OS in uefi 
> >>> mode, the combination should work, I guess.
> >>>
> >>> Anyone with a tip or a tric..?
> >>>
> >>> This is proxmox 4.4-20, so it's a bit older. I could try it on a 
> >>> fresh new proxmox 5.2 install, but first I wanted to ask here.
> >>>
> >>> Anyone?
> >>>
> >>> MJ
> >>> _______________________________________________
> >>> pve-user mailing list
> >>> pve-user at pve.proxmox.com
> >>> https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
> >>
> >>
> > _______________________________________________
> > pve-user mailing list
> > pve-user at pve.proxmox.com
> > https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
> _______________________________________________
> pve-user mailing list
> pve-user at pve.proxmox.com
> https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
> 


-- 
Christian Meiring

Wilh. Wülfing GmbH & Co.KG
Weseler Landstraße 26
D - 46325 Borken

Tel +49 2861 8004 193
Fax +49 2861 8004 243

http://www.wilh-wuelfing.de
eMail: christian.meiring at wilh-wuelfing.de

Kommanditgesellschaft, Sitz Borken,
Reg.-Gericht Coesfeld, HRA 3479

Persönlich haftende Gesellschafterin:
Wülfing-Beteiligungs-GmbH, Sitz Borken,
Reg.-Gericht Coesfeld, HRB 5340

Geschäftsführer: Johannes Dowe, Josef Kölker


More information about the pve-user mailing list