[PVE-User] Problems with HP Smart Array P400 and ZFS

Dreyer, Jan, SCM-IT Jan.Dreyer at arvato.com
Fri Aug 24 11:51:02 CEST 2018


Hi,

my configuration:
HP DL380 G5 with Smart Array P400
Proxmox VE 5.2-1
name: 4.4.128-1-pve #1 SMP PVE 4.4.128-111 (Wed, 23 May 2018 14:00:02 +0000) x86_64 GNU/Linux
This system is currently running ZFS filesystem version 5.

My problem: When trying to update to a higher kernel (I tried 4.10 and 4.15 series), the initrd is not able to detect the cciss devices, and as such not able to load the ZFS pools, including the root pool.
Falling back to kernel 4.4 doesn’t let me use the ZFS cache file system though. :-(

Any hints on how to detect the raid controller device in initrd?

Gruß / Regards
—
Jan Dreyer
IT Administrator — Operations — A-SCM-IT IOX Expert
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: Message signed with OpenPGP
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20180824/63f35f83/attachment-0001.sig>


More information about the pve-user mailing list