[PVE-User] WARNING: zfs 0.7.7 has regression

Fabian Gr├╝nbichler f.gruenbichler at proxmox.com
Tue Apr 10 12:45:43 CEST 2018


On Tue, Apr 10, 2018 at 11:43:11AM +0200, Uwe Sauter wrote:
> Hi all,
> 
> I discourage you from updating ZFS to version 0.7.7 as it contains a regression. Version 0.7.8 was released today that reverts the
> commit that introduced the regression.
> 
> For Infos check: https://github.com/zfsonlinux/zfs/issues/7401

we already released new kernels with a fixed ZFS module yesterday, and
the affected one has only been available in pvetest before being
superceded by the patched one.

the bug also looks unlikely to trigger on PVE systems, since you need to
create lots of files in a short time in one directory with a filename
pattern that triggers collisions. it triggered easier on CentOS systems
because their version of coreutil's 'cp' randomized the order of copied
files in a recursive copy operation (thus potentially randomly hitting a
filename sequence that triggers).

analysis is not yet complete though, so upgrading is recommended in case
you installed the broken version from pvetest.

affected (only those specific packages and versions!):
pve-kernel-4.15.15-1-pve in version 4.15.15-5
pve-kernel-4.13.16-1-pve in version 4.13.16-46

fixed (and everything afterwards):
pve-kernel-4.15.15-1-pve in version 4.15.15-6
pve-kernel-4.13.16-2-pve in version 4.13.16-47



More information about the pve-user mailing list