[PVE-User] pveceph : Unable to add any OSD

Alwin Antreich a.antreich at proxmox.com
Tue Sep 26 14:21:36 CEST 2017


On Mon, Sep 25, 2017 at 08:25:23PM +0200, Phil Schwarz wrote:
> OK, thanks.
> Did update the sources.list files to the test & pvetest repo.
> update &dist-upgrade
>
> But, the software versions remain identical :
For now there are no new versions.

>
>
>  dpkg -l |grep ceph
> ii  ceph                                 12.2.0-pve1 amd64
> distributed storage and file system
> ii  ceph-base                            12.2.0-pve1 amd64        common
> ceph daemon libraries and management tools
> ii  ceph-common                          12.2.0-pve1 amd64        common
> utilities to mount and interact with a ceph storage cluster
> ii  ceph-mgr                             12.2.0-pve1 amd64        manager
> for the ceph distributed storage system
> ii  ceph-mon                             12.2.0-pve1 amd64        monitor
> server for the ceph storage system
> ii  ceph-osd                             12.2.0-pve1 amd64        OSD server
> for the ceph storage system
> ii  libcephfs1                           10.2.5-7.2 amd64        Ceph
> distributed file system client library
> ii  libcephfs2                           12.2.0-pve1 amd64        Ceph
> distributed file system client library
> ii  python-cephfs                        12.2.0-pve1 amd64        Python 2
> libraries for the Ceph libcephfs library
>
>
>
>
>
> dpkg -l |grep "pve-"
> ii  libpve-access-control                5.0-6 amd64        Proxmox VE
> access control library
> ii  libpve-common-perl                   5.0-18 all          Proxmox VE base
> library
> ii  libpve-guest-common-perl             2.0-12 all          Proxmox VE
> common guest-related modules
> ii  libpve-http-server-perl              2.0-6 all          Proxmox
> Asynchrounous HTTP Server Implementation
> ii  libpve-storage-perl                  5.0-15 all          Proxmox VE
> storage management library
> ii  pve-cluster                          5.0-14 amd64        Cluster
> Infrastructure for Proxmox Virtual Environment
> ii  pve-container                        2.0-16 all          Proxmox VE
> Container management tool
> ii  pve-docs                             5.0-9 all          Proxmox VE
> Documentation
> ii  pve-firewall                         3.0-3 amd64        Proxmox VE
> Firewall
> ii  pve-firmware                         2.0-2 all          Binary firmware
> code for the pve-kernel
> ii  pve-ha-manager                       2.0-2 amd64        Proxmox VE HA
> Manager
> ii  pve-kernel-4.10.17-2-pve             4.10.17-20 amd64        The Proxmox
> PVE Kernel Image
> ii  pve-kernel-4.10.17-3-pve             4.10.17-23 amd64        The Proxmox
> PVE Kernel Image
> ii  pve-libspice-server1                 0.12.8-3 amd64        SPICE remote
> display system server library
> ii  pve-manager                          5.0-32 amd64        Proxmox Virtual
> Environment Management Tools
> ii  pve-qemu-kvm                         2.9.1-1 amd64        Full
> virtualization on x86 hardware
>
>
> Therefore, the pveceph createosd issue is the same : A failure in creating
> the OSD..
Yes, as long as we have no new packages, the state is the same. But
hopefully soon, ceph will distribute a bug fix version.

>
> I beg i've to wait for 5.1.
> What's the delay between the last 5.1 beta and the final 5.1 stable ?
There is only a PVE beta if there is a new debian release. So no beta
for 5.1.
>
> Don't knwo if i can wait or have to destroy the cluster and recreate it OUT
> OF proxmox .
>
> Would be sad, but it seems i'm the only one having problem in creating OSD,
> and i can't wait for my OSD to be added; at least, i can't wait a full
> month..
You don't need to destroy your cluster, it is a issue with rocksdb and
happens on old hardware, like Opterons. So if your MONs are working fine
and you have some space left on your ceph, then it should be no problem
after package update to continue using the older hardware.

>
> Thanks
>
>
> Le 25/09/2017 à 17:27, Alwin Antreich a écrit :
> > On Mon, Sep 25, 2017 at 05:07:27PM +0200, Phil Schwarz wrote:
> > > Thanks for your answer,
> > > related to Alexandre Derumier's one  on July :
> > > https://www.mail-archive.com/ceph-users@lists.ceph.com/msg39234.html
> > >
> > > Do you have any idea when the pve repository will have the new .deb files ?
> > PVE 5.1 release is planned for mid/end October, latest then, the
> > packages are in the repository. The pvetest repository gets it earlier.
> >
> > https://forum.proxmox.com/threads/planning-proxmox-ve-5-1-ceph-luminous-kernel-4-13-latest-zfs-lxc-2-1.36943/
> > >
> > > Thanks
> > >
> > >
> > > Le 25/09/2017 à 10:59, Alwin Antreich a écrit :
> > > > Hi Phil,
> > > >
> > > > On Sat, Sep 23, 2017 at 03:26:10PM +0200, Phil Schwarz wrote:
> > > > > Hi, thanks for the advice.
> > > > >
> > > > > 1. Did a ceph activate of the device; the process segfaulted :
> > > > What hardware do you use? But I think it looks like the following bug:
> > > > http://tracker.ceph.com/issues/20529
> > > >
> > > > It has been fixed upstream and is in ceph now, but it will take a couple
> > > > of days till it will appear in our repositories.
> > > >
> > > > >
> > > > >
> > >
> > > _______________________________________________
> > > pve-user mailing list
> > > pve-user at pve.proxmox.com
> > > https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
> >
> > _______________________________________________
> > pve-user mailing list
> > pve-user at pve.proxmox.com
> > https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
> >
>
>
--
Cheers,
Alwin



More information about the pve-user mailing list