[PVE-User] PVE Cluster and /etc/hosts.conf

Gilberto Nunes gilberto.nunes32 at gmail.com
Mon Sep 18 23:32:52 CEST 2017


But that's my point!
I always do what I told before, 'cause I suppose that all cluster/migrate
traffic run over my private network... Is this no certain, so?





2017-09-18 18:23 GMT-03:00 <lemonnierk at ulrar.net>:

> Well if it works, sure. I know my nodes can't have corosync use eth0, so
> I have to add the ring0 paramter to force that to use the local network,
> but that's might not be a problem for you.
>
> Just saying don't be surprised when you see your VM migration use your
> public interface instead of the local ones :)
>
> On Mon, Sep 18, 2017 at 06:21:46PM -0300, Gilberto Nunes wrote:
> > Oh I see....
> >
> >
> > But that's ok if I continue use the /etc/hosts.conf as I pointed before.
> > right?
> >
> >
> > 2017-09-18 18:12 GMT-03:00 <lemonnierk at ulrar.net>:
> >
> > > Unfortunatly proxmox doesn't really use that for everything, it uses
> the
> > > machines hostnames and you can't do anything about it.
> > >
> > > If you do something like pvecm add pve01 -ring0addr 10.1.1.XX you can
> > > force corosync to use your local network, but if your hostnames resolve
> > > to public IPs, VM migration and stuff like that will use that anyway.
> > >
> > > It would be great to have an option to make proxmox use something else
> > > than the hostname, but as far as I know there is no real way around it
> > > for now.
> > >
> > > On Mon, Sep 18, 2017 at 05:34:47PM -0300, Gilberto Nunes wrote:
> > > > Hi guys...
> > > >
> > > > I always do, as good practices, adjust the /etc/hosts.conf, in order
> to
> > > > resolve the internal IP to the machine name, when creating a cluster.
> > > > So, I puted this in /etc/hosts.conf in each node:
> > > >
> > > > 127.0.0.1   localhost
> > > > 10.1.1.10 pve01 pvelocalhost
> > > > 10.1.1.20 pve02
> > > > 10.1.1.30 pve03
> > > >
> > > > just altering the pvelocalhost according to the node...
> > > >
> > > > Now, when I add the node to the cluster, I refer to the name of that
> > > > "primary" node, such this:
> > > >
> > > > pvecm add pve01
> > > >
> > > > Is this correct???
> > > >
> > > > P.S.: I just acted like this, because I believe that to make a
> private
> > > > network between the servers, do the cluster more reliable than make
> all
> > > > traffic from clusters node concurrer with LAN traffic...
> > > >
> > > > Thanks anyway
> > > > _______________________________________________
> > > > pve-user mailing list
> > > > pve-user at pve.proxmox.com
> > > > https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
> > >
> > > _______________________________________________
> > > pve-user mailing list
> > > pve-user at pve.proxmox.com
> > > https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
> > >
> > >
> > _______________________________________________
> > pve-user mailing list
> > pve-user at pve.proxmox.com
> > https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
>
> _______________________________________________
> pve-user mailing list
> pve-user at pve.proxmox.com
> https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
>
>


More information about the pve-user mailing list