[PVE-User] Need install ceph hammer on pve 3.4

Alwin Antreich a.antreich at proxmox.com
Tue Oct 31 08:23:15 CET 2017


Hi,

On Tue, Oct 31, 2017 at 10:36:05AM +0600, Жюль Верн wrote:
> Hi, i know that pve 3.4 and ceph hammer is EOL. But for some tests i need
> to install it. I have pve 3.4 3 nodes in cluster. Now i need to install
> ceph hammer on it. But there is no working repo for ceph hammer install.
> Try manually download and install .deb packages from ceph repo. But for
> example when install ceph_0.94.9-1~bpo70+1_amd64.deb get error:
>
> dpkg: regarding ceph_0.94.9-1~bpo70+1_amd64.deb containing ceph:
>  ceph breaks python-ceph (<< 0.92-1223)
>   python-ceph (version 0.80.8-1~bpo70+1) is present and installed.
>
> dpkg: error processing ceph_0.94.9-1~bpo70+1_amd64.deb (--install):
>  installing ceph would break python-ceph, and
>  deconfiguration is not permitted (--auto-deconfigure might help)
> Errors were encountered while processing:
>  ceph_0.94.9-1~bpo70+1_amd64.deb
>
> Plz help me complete this quest ! ))
> _______________________________________________
> pve-user mailing list
> pve-user at pve.proxmox.com
> https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
Someone in the forum has the same target, there is also the repository
link, as the ceph packages have to downloaded directly from ceph.com.
You should be able to hook it up as a repository, for depencies, etc...

https://forum.proxmox.com/threads/ceph-hammer-install-on-pve-3-4.37587/#post-186200

--
Cheers,
Alwin



More information about the pve-user mailing list