[PVE-User] Proxmox VE 5.1 released!

Martin Maurer martin at proxmox.com
Tue Oct 24 15:39:17 CEST 2017


We are very happy to announce the final release of our Proxmox VE 5.1 - 
based on the latest Debian 9.2 and a modern Linux Kernel 4.13 with ZFS 
0.7.2.

With Proxmox VE 5.1 Ceph Luminous is finally production-ready and fully 
supported by the Proxmox support team. The new BlueStore storage backend 
for Ceph boosts performance (in some cases up to 2x for writes), got 
full data checksumming and built-in compression - BlueStore is the new 
default for OSDs.

And as always we have included countless bugfixes and improvements on a 
lot of places.

Release notes
https://pve.proxmox.com/wiki/Roadmap#Proxmox_VE_5.1

Download
https://www.proxmox.com/en/downloads
Alternate ISO download:
http://download.proxmox.com/iso/

Source Code
https://git.proxmox.com

Bugtracker
https://bugzilla.proxmox.com

FAQ
Q: Can I install Proxmox VE 5.1 on top of Debian Stretch?
A: Yes, see 
https://pve.proxmox.com/wiki/Install_Proxmox_VE_on_Debian_Stretch

Q: Can I dist-upgrade Proxmox VE 4.4 to 5.1 with apt dist-upgrade?
A: Yes, see https://pve.proxmox.com/wiki/Upgrade_from_4.x_to_5.0

Q: I am running Ceph Server on V4.4 in a production setup - should I 
plan the upgrade now?
A: Yes. Ceph packages in Proxmox VE 5.1 are based on the latest Ceph 
Luminous release, please follow these wiki article - 
https://pve.proxmox.com/wiki/Ceph_Jewel_to_Luminous and 
https://pve.proxmox.com/wiki/Upgrade_from_4.x_to_5.0

Many thank you's to our active community for all feedback, testing, bug 
reporting and patch submissions!

-- 
Best Regards,

Martin Maurer
Proxmox VE project leader



More information about the pve-user mailing list