[PVE-User] problem with cluster configuration, please help

Жюль Верн dedneral at gmail.com
Wed Oct 18 12:54:46 CEST 2017


I need to update from 3.4 pve to 5, thats my current task. And that is test
servers. I test multicast and its ok.

2017-10-18 16:50 GMT+06:00 Thomas Lamprecht <t.lamprecht at proxmox.com>:

> On 10/18/2017 12:13 PM, Жюль Верн wrote:
> > I read documentation and know how to create a cluster. Problem now is
> that
> > no quorum between node1 and node2 of my cluster. Search problem in log,
> but
> > nothing find. Try pvecm expected 1 command to add node3 to cluster but it
> > not help.
> >
>
> I assume that the following is the log of your node addition try:
>
> > Starting cluster:
> >    Checking if cluster has been disabled at boot... [  OK  ]
> >    Checking Network Manager... [  OK  ]
> >    Global setup... [  OK  ]
> >    Loading kernel modules... [  OK  ]
> >    Mounting configfs... [  OK  ]
> >    Starting cman... [  OK  ]
> >    Waiting for quorum... [  OK  ]
> >    Starting fenced... [  OK  ]
> >    Starting dlm_controld... [  OK  ]
> >    Tuning DLM kernel config... [  OK  ]
> >    Unfencing self... [  OK  ]
> > waiting for quorum...
>
> Is this a PVE 3.4 cluster? If you setup a new cluster please
> start with PVE 5, as PVE 3.4 is now quite outdated and EOL.
> And remember PVE 3.4 can not be mixed with PVE 4.X or 5.X, that won't work.
>
> did those checks pass:
> https://pve.proxmox.com/pve-docs/chapter-pvecm.html#
> cluster-network-requirements
>
> >> On Tue, Oct 17, 2017 at 9:05 AM, Жюль Верн <dedneral at gmail.com> wrote:
> >>
> >>> Good day ! I install three nodes of proxmox from image. And try to
> >> create a
> >>> cluster. Command pvecm create proxtest on node1 was successful, type
> >> pvecm
> >>> add on node2:
> >>>
> >>> root at pve:~# pvecm add 10.22.16.50
> >>> The authenticity of host '10.22.16.50 (10.22.16.50)' can't be
> >> established.
> >>> ECDSA key fingerprint is 1c:e8:06:20:76:4d:a0:89:f1:22:
> >> 92:81:1f:af:b2:1b.
> >>> Are you sure you want to continue connecting (yes/no)? yes
> >>> root at 10.22.16.50's password:
> >>> node pve already defined
> >>> copy corosync auth key
> >>> stopping pve-cluster service
> >>> Stopping pve cluster filesystem: pve-cluster.
> >>> backup old database
> >>> Starting pve cluster filesystem : pve-cluster.
> >>> Starting cluster:
> >>>    Checking if cluster has been disabled at boot... [  OK  ]
> >>>    Checking Network Manager... [  OK  ]
> >>>    Global setup... [  OK  ]
> >>>    Loading kernel modules... [  OK  ]
> >>>    Mounting configfs... [  OK  ]
> >>>    Starting cman... [  OK  ]
> >>>    Waiting for quorum... [  OK  ]
> >>>    Starting fenced... [  OK  ]
> >>>    Starting dlm_controld... [  OK  ]
> >>>    Tuning DLM kernel config... [  OK  ]
> >>>    Unfencing self... [  OK  ]
> >>> waiting for quorum...
> >>>
> >>> At this moment i type pvecm add ... command on node3 and get "unable to
> >>> copy ssh ID" What i doing wrong ?
>
>
>
>
>


More information about the pve-user mailing list