[PVE-User] problem with cluster configuration, please help

Жюль Верн dedneral at gmail.com
Wed Oct 18 12:13:07 CEST 2017


I read documentation and know how to create a cluster. Problem now is that
no quorum between node1 and node2 of my cluster. Search problem in log, but
nothing find. Try pvecm expected 1 command to add node3 to cluster but it
not help.

2017-10-18 16:00 GMT+06:00 <pve-user-request at pve.proxmox.com>:

> Send pve-user mailing list submissions to
>         pve-user at pve.proxmox.com
>
> To subscribe or unsubscribe via the World Wide Web, visit
>         https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
> or, via email, send a message with subject or body 'help' to
>         pve-user-request at pve.proxmox.com
>
> You can reach the person managing the list at
>         pve-user-owner at pve.proxmox.com
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of pve-user digest..."
>
>
> Today's Topics:
>
>    1. Re: problem with cluster configuration, please help
>       (Yannis Milios)
>    2. Re: Proxmox VE 5.x deployments with Ansible (now with
>       clustering/acl management) (Musee Ullah)
>    3. Proxmox 4.4, Ceph Hammer and Ceph Luminous (Mark Schouten)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Tue, 17 Oct 2017 12:52:14 +0100
> From: Yannis Milios <yannis.milios at gmail.com>
> To: PVE User List <pve-user at pve.proxmox.com>
> Subject: Re: [PVE-User] problem with cluster configuration, please
>         help
> Message-ID:
>         <CAFiF2Opmq-t7jea_r3nvC_PTmYyM1yiSbhP-6j2RvrBAK9z09A@
> mail.gmail.com>
> Content-Type: text/plain; charset="UTF-8"
>
> >> node pve already defined
>
> To add additional nodes to the cluster, you need to run 'pvecm add
> <IP-ADDRESS-OF-1st-NODE> *on* the 2nd and 3rd node.
> For example let's assume you have 3 nodes (pve1,pve2,pve3).
>
> To create the cluster:
> -----------------------
>
> on pve1:
> pvecm create pvecluster1
>
> To add additional nodes:
> ------------------------
>
> on pve2:
> pvecm add <IP-ADDRESS-OF-PVE1>
>
> on pve3:
> pvecm add <IP-ADDRESS-OF-PVE1>
>
> More info here:
> https://pve.proxmox.com/wiki/Proxmox_VE_4.x_Cluster#Create_the_cluster
>
> and
>
> https://pve.proxmox.com/wiki/Proxmox_VE_4.x_Cluster#Remove_a_cluster_node
>
> Yannis
>
> On Tue, Oct 17, 2017 at 9:05 AM, Жюль Верн <dedneral at gmail.com> wrote:
>
> > Good day ! I install three nodes of proxmox from image. And try to
> create a
> > cluster. Command pvecm create proxtest on node1 was successful, type
> pvecm
> > add on node2:
> >
> > root at pve:~# pvecm add 10.22.16.50
> > The authenticity of host '10.22.16.50 (10.22.16.50)' can't be
> established.
> > ECDSA key fingerprint is 1c:e8:06:20:76:4d:a0:89:f1:22:
> 92:81:1f:af:b2:1b.
> > Are you sure you want to continue connecting (yes/no)? yes
> > root at 10.22.16.50's password:
> > node pve already defined
> > copy corosync auth key
> > stopping pve-cluster service
> > Stopping pve cluster filesystem: pve-cluster.
> > backup old database
> > Starting pve cluster filesystem : pve-cluster.
> > Starting cluster:
> >    Checking if cluster has been disabled at boot... [  OK  ]
> >    Checking Network Manager... [  OK  ]
> >    Global setup... [  OK  ]
> >    Loading kernel modules... [  OK  ]
> >    Mounting configfs... [  OK  ]
> >    Starting cman... [  OK  ]
> >    Waiting for quorum... [  OK  ]
> >    Starting fenced... [  OK  ]
> >    Starting dlm_controld... [  OK  ]
> >    Tuning DLM kernel config... [  OK  ]
> >    Unfencing self... [  OK  ]
> > waiting for quorum...
> >
> > At this moment i type pvecm add ... command on node3 and get "unable to
> > copy ssh ID" What i doing wrong ?
> > _______________________________________________
> > pve-user mailing list
> > pve-user at pve.proxmox.com
> > https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
> >
>
>
> ------------------------------
>
> Message: 2
> Date: Tue, 17 Oct 2017 13:46:24 -0700
> From: Musee Ullah <lae at lae.is>
> To: PVE User List <pve-user at pve.proxmox.com>
> Subject: Re: [PVE-User] Proxmox VE 5.x deployments with Ansible (now
>         with clustering/acl management)
> Message-ID: <1508273184.2692.34.camel at lae.is>
> Content-Type: text/plain; charset="utf-8"
>
> Hi all,
>
> There's now a step by step section for writing a playbook for deploying a
> Proxmox cluster with this role:
>
> https://github.com/lae/ansible-role-proxmox/blob/
> master/README.md#deploying-a-fully-featured-pve-5x-cluster
>
> (in case that line breaks, scroll down to the "Deploying a fully-featured
> PVE 5.x cluster" section:
> https://github.com/lae/ansible-role-proxmox/tree/master )
>
> --
> Musee Ullah <lae at lae.is>
>
> 2017-10-16 (月) の 02:36 -0700 に Musee Ullah さんは書きました:
> > A new version of this Ansible role has been published. It now supports
> > creating and adding nodes to a PVE cluster, as well as managing groups,
> > users and access control lists either within a single node or within a
> > PVE cluster.
> >
> > See release notes for a full list of changes:
> > https://github.com/lae/ansible-role-proxmox/releases/tag/v1.4.0
> >
> > As always, this can be installed/updated from Galaxy (pass --force if
> > updating):
> >
> > ansible-galaxy install lae.proxmox
> >
> > To enable clustering, set "pve_cluster_enabled" to yes in your group
> > variables. If you need to specify a separate ring0 (or extra ring1)
> > address, refer to the README:
> > https://github.com/lae/ansible-role-proxmox/blob/master/README.md
> >
> > A quick configuration of users/groups/ACLs:
> >
> > pve_groups:
> >   - name: Admins
> > pve_users:
> >   - name: admin@pam
> >     groups: [ "Admins" ]
> > pve_acls:
> >   - path: /
> >     roles: [ "Administrator" ]
> >     groups: [ "Admins" ]
> >
> > This'll create a user "admin@pam" in the group "Admins", with
> > Administrator level access to the entire cluster (or node). For more
> > examples, refer to the README.
> >
> > As always, I'm open to any feedback, bug reports, and feature requests.
> >
> > Hope you'll try it out!
> >
> > --
> > Musee Ullah <lae at lae.is>
> >
> > 2017-10-03 (火) の 17:19 -0700 に Musee Ullah さんは書きました:
> > > Hey all,
> >
> > It's been a while. I just a cut a release of an Ansible role that now
> > supports deploying PVE 5.x nodes (it still supports 4.x), as well as
> > configuring HTTPS certificates for the nodes. Most of the requests
> > from the previous email thread (back in March) were also implemented
> > long ago, but I happened to not cut a release for them until now.
> > (For more info, check the releases page:
> > https://github.com/lae/ansible-role-proxmox/releases.)
> >
> > You can see a successful test deployment of 5.x/Debian Stretch here:
> > https://travis-ci.org/lae/ansible-role-proxmox/jobs/282937447#L4975 -
> > I've also successfully tested creating a cluster with pvecm locally
> > using this (I'll eventually add this functionality into the Ansible
> > role).
> >
> > Anyway, if any of you have time to do a 5.x deployment (or even
> > manage an existing 4.x deployment) using this role, I'd love to get
> > your input as to what could be improved.
> >
> > The role is available on Ansible Galaxy at
> > https://galaxy.ansible.com/lae/proxmox/ (the README tab has a
> > quickstart section with an example single host deployment).
> >
> > Also one more thing to note - this can easily be used to keep 4.x and
> > 5.x clusters up to date (it'll upgrade to the latest in their series)
> > - but it can't be used for automating an upgrade from 4.x to 5.x (too
> > many variables to consider, honestly).
> > _______________________________________________
> > pve-user mailing list
> > pve-user at pve.proxmox.com
> > https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
> >
> -------------- next part --------------
> A non-text attachment was scrubbed...
> Name: signature.asc
> Type: application/pgp-signature
> Size: 228 bytes
> Desc: This is a digitally signed message part
> URL: <http://pve.proxmox.com/pipermail/pve-user/
> attachments/20171017/52e72599/attachment-0001.sig>
>
> ------------------------------
>
> Message: 3
> Date: Wed, 18 Oct 2017 10:47:09 +0200
> From: Mark Schouten <mark at tuxis.nl>
> To: pve-user at pve.proxmox.com
> Subject: [PVE-User] Proxmox 4.4, Ceph Hammer and Ceph Luminous
> Message-ID: <781776690-25556 at kerio.tuxis.nl>
> Content-Type: text/plain; charset="utf-8"
>
> Hi,
>
>
> I have a Proxmox 4.4 cluster, which is connected to two Ceph clusters. One
> of them is running Hammer, the other is running Luminous (since this
> morning).
>
>
> All running VM's seem to be fine and working, but the Proxmox webinterface
> froze. It looks like the default Rados-client in Debian (
> root at proxmox2-1:~# rados -v
> ceph version 0.80.7 (6c0127fcb58008793d3c8b62d925bc91963672a3)
> )
> is incompatible with Ceph Luminous.
>
>
>
> 2017-10-18 10:43:54.285544 7fa394755700 -1 failed to decode message of
> type 59 v1: buffer::malformed_input: __PRETTY_FUNCTION__ unknown encoding
> version > 9
>
>
> That is a bit surprising, imho. But OK, there are a few versions in
> between.
>
>
> The question is, can I install a Ceph Luminous client on the Proxmox
> machines (add Ceph Luminous to the sources.list, dist-upgrade) and be
> happy? Or am I going to have trouble connecting to my older Hammer cluster
> using a Luminous client?
>
>
> For now, I disabled the whole storage-entry in storage.cfg for the
> Luminous cluster to prevent Proxmox from hanging on /usr/bin/rados. Has
> anybody installed a Luminous client on Proxmox 4.4 ?
>
> Met vriendelijke groeten,
>
> --
> Kerio Operator in de Cloud? https://www.kerioindecloud.nl/
> Mark Schouten  | Tuxis Internet Engineering
> KvK: 61527076 | http://www.tuxis.nl/
> T: 0318 200208 | info at tuxis.nl
>
> ------------------------------
>
> Subject: Digest Footer
>
> _______________________________________________
> pve-user mailing list
> pve-user at pve.proxmox.com
> https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
>
>
> ------------------------------
>
> End of pve-user Digest, Vol 115, Issue 17
> *****************************************
>


More information about the pve-user mailing list