[PVE-User] cant update: pve-firmware : Conflicts: firmware-linux-free

Emmanuel Kasper e.kasper at proxmox.com
Mon Oct 16 14:26:11 CEST 2017


On 10/14/2017 10:52 AM, Stefan Fuhrmann wrote:
> Hello all,
> 
> I want to update the system but get an error:
>  
> The following packages have unmet dependencies:
>  pve-firmware : Conflicts: firmware-linux-free but 3.4 is to be installed
> E: Broken packages
> 
>  firmware-linux-free is not installed

for whatever reason the package manager is trying to install the
firmware-linux-free which is not needed by PVE

try to give a hint to the package manager that you want pve-firmware
and not firmware-linux-free by doing:

apt-get install proxmox-ve

then probably you will be asked if you to remove firmware-linux-free,
answer yes, and after that try the upgrade again.







More information about the pve-user mailing list