[PVE-User] pveceph : Unable to add any OSD : SOLVED

Phil Schwarz infolist at schwarz-fr.net
Thu Oct 5 22:45:19 CEST 2017


Hi,
did upgrade from 12.2.0-pve1 to 12.2.1-pve1, zapped the disked, added as 
a bluestore OSD......Tada! It worked!

Thanks for all! problem solved !

Best regards

Le 26/09/2017 à 14:34, Phil Schwarz a écrit :
> Le 26/09/2017 à 14:21, Alwin Antreich a écrit :
>> On Mon, Sep 25, 2017 at 08:25:23PM +0200, Phil Schwarz wrote:
>>> OK, thanks.
>>> Did update the sources.list files to the test & pvetest repo.
>>> update &dist-upgrade
>>>
>>> But, the software versions remain identical :
>> For now there are no new versions.
> OK
>>
>>>
>>>
> ...
>>>
>>>
>>> Therefore, the pveceph createosd issue is the same : A failure in creating
>>> the OSD..
>> Yes, as long as we have no new packages, the state is the same. But
>> hopefully soon, ceph will distribute a bug fix version.
> I'm glad to read such great news!
>>
>>>
>>> I beg i've to wait for 5.1.
>>> What's the delay between the last 5.1 beta and the final 5.1 stable ?
>> There is only a PVE beta if there is a new debian release. So no beta
>> for 5.1.
> OK, wasn't aware of that process.
>>>
>>> Don't knwo if i can wait or have to destroy the cluster and recreate it OUT
>>> OF proxmox .
>>>
>>> Would be sad, but it seems i'm the only one having problem in creating OSD,
>>> and i can't wait for my OSD to be added; at least, i can't wait a full
>>> month..
>> You don't need to destroy your cluster, it is a issue with rocksdb and
>> happens on old hardware, like Opterons. So if your MONs are working fine
>> and you have some space left on your ceph, then it should be no problem
>> after package update to continue using the older hardware.
> 
> You got focused on the main pb...My cluster is 103% full...
> No solution apart from waiting, apparently.
> 
> Thanks for your support.
> Shall wait now.
> 
> Thanks
> Best regards
>>
>>>
>>> Thanks
>>>
>>>
>>> Le 25/09/2017 à 17:27, Alwin Antreich a écrit :
>>>> On Mon, Sep 25, 2017 at 05:07:27PM +0200, Phil Schwarz wrote:
>>>>> Thanks for your answer,
>>>>> related to Alexandre Derumier's one  on July :
>>>>> https://www.mail-archive.com/ceph-users@lists.ceph.com/msg39234.html
>>>>>
>>>>> Do you have any idea when the pve repository will have the new .deb files ?
>>>> PVE 5.1 release is planned for mid/end October, latest then, the
>>>> packages are in the repository. The pvetest repository gets it earlier.
>>>>
>>>> https://forum.proxmox.com/threads/planning-proxmox-ve-5-1-ceph-luminous-kernel-4-13-latest-zfs-lxc-2-1.36943/
>>>>>
>>>>> Thanks
>>>>>
>>>>>
>>>>> Le 25/09/2017 à 10:59, Alwin Antreich a écrit :
>>>>>> Hi Phil,
>>>>>>
>>>>>> On Sat, Sep 23, 2017 at 03:26:10PM +0200, Phil Schwarz wrote:
>>>>>>> Hi, thanks for the advice.
>>>>>>>
>>>>>>> 1. Did a ceph activate of the device; the process segfaulted :
>>>>>> What hardware do you use? But I think it looks like the following bug:
>>>>>> http://tracker.ceph.com/issues/20529
>>>>>>
>>>>>> It has been fixed upstream and is in ceph now, but it will take a couple
>>>>>> of days till it will appear in our repositories.
>>>>>>
>>>>>>>
>>>>>>>
>>>>>
>>>>> _______________________________________________
>>>>> pve-user mailing list
>>>>> pve-user at pve.proxmox.com
>>>>> https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
>>>>
>>>> _______________________________________________
>>>> pve-user mailing list
>>>> pve-user at pve.proxmox.com
>>>> https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
>>>>
>>>
>>>
>> --
>> Cheers,
>> Alwin
>>
>> _______________________________________________
>> pve-user mailing list
>> pve-user at pve.proxmox.com
>> https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
>>
> 
> _______________________________________________
> pve-user mailing list
> pve-user at pve.proxmox.com
> https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
> 



More information about the pve-user mailing list