[PVE-User] sbin/unconfigured.sh

Steve steve at easy2boot.com
Fri May 19 14:51:06 CEST 2017

I think the problem is with grub4dos.

If I use this menu from a FAT32 USB drive

title ProxMox lvm2root=sda1
kernel /boot/linux26 ro ramdisk_size=16777216 lvm2root=/dev/sda1 rw quiet
initrd /boot/initrd.img

then it does not work and I get the Installation aborted message

but if I use the same menu in grub2 from the same drive,

menuentry 'Install Proxmox VE sda1' --class debian --class gnu-linux
--class gnu --class os {
linux /boot/linux26 ro ramdisk_size=16777216 lvm2root=/dev/sda1 rw quiet
initrd /boot/initrd.img

then it works and loads the installer GUI.

I also note that it does not change to 1024x768 when booting via grub4dos,
so I added


and now it works!!!

On 19 May 2017 at 12:46, Fabian Grünbichler <f.gruenbichler at proxmox.com>

> On Fri, May 19, 2017 at 10:27:20AM +0100, Steve wrote:
> > If I type xinit it says /bin/sh: xinit: not found
> >
> > I am the author of easy2boot which is a USB multiboot tool to allow
> people
> > to boot from 100's of different ISOs (or images) all from one USB stick.
> > I have been asked by a user to get proxmox 4 working.
> > 3.2 works because I can run the unconfigured.sh from the command line
> >
> > http://rmprepusb.blogspot.co.uk/2014/03/add-proxmox-isos-
> to-easy2boot.html
> > http://www.easy2boot.com
> >
> > I tried setting proxdebug and  root=/dev/sdb1  or lvm2root=/dev/sdb1 to
> get
> > it to mount the FAT32 partition to /mnt. I do not need to manually use
> any
> > mount commands, it just automatically runs init but this causes an early
> > error message of
> > mount: mounting /dev/sdb1 on /mnt failed: Invalid argument
> > but if I use the mount command I can see that /mnt is present as a vfat
> > /dev/sdb1
> > If I press CTRL+D to continue, it fails in the exact same place with
> > Installation aborted - unable to continue.
> > Note that this is not using my script at all, just the original init
> script
> > - I have not broken into the boot process because it picks up the
> lvm2root
> > parameter.
> >
> > I am so *near*, yet I just cannot get the unconfigured.sh script to run
> in
> > this way...
> >
> > thanks for your help.
> > Steve
> I just did a quick test run using Grub:
> loopback test PATHTOISO
> linux (test)/boot/linux26 proxdebug ramdisk_size=16777216 rw
> initrd (test)/boot/initrd.img
> boot
> drops me into the initrd debug shell
> if I do the following (major/minor depend on your disk configuration,
>   check /sys/class/block/XXX/dev where XXX is your usb partition where
>   the iso is)
> mknod /tmp/usbdev b MAJOR MINOR
> mkdir /tmp/usbmnt
> mount /tmp/usbdev /tmp/usbmnt
> mount /tmp/usbmnt/PATHTOISO /mnt
> followed by lines 294ff of the init script launch the graphical
> installer (although the resolution is messed up - probably because I did
> not bother to change any of the graphic stuff in Grub), and I am able to
> complete the installation..
> so I think it must be something in your environment / setup.
> (note that there are TWO debug shells, one in the initrd with very
> limited commands, and one in the installer environment with access to a
> lot more tools - a quick test is to run something like "lsblk", since
> that only exists in the latter environment ;). maybe your switch to the
> installer environment did not work, and you are still in the initrd
> shell? that would explain why you can't execute "xinit")
> _______________________________________________
> pve-user mailing list
> pve-user at pve.proxmox.com
> https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user

More information about the pve-user mailing list