[PVE-User] Backup to Ceph / NFSv4

Uwe Sauter uwe.sauter.de at gmail.com
Thu May 18 15:31:57 CEST 2017

Am 18.05.2017 um 15:04 schrieb Emmanuel Kasper:
> On 05/18/2017 02:56 PM, Uwe Sauter wrote:
>> # mount -t nfs -o vers=4,rw,sync <host>:$SHARE /mnt
>> mount.nfs: mounting aurel:/proxmox-infra failed, reason given by server: No such file or directory
> aurel:/proxmox-infra
> are you using here the right path ?
> looking at your exports file you should try to mount
> aurel:/exports/proxmox-infra

As I wrote:

"Tested with $SHARE being several values, e.g. /exports/proxmox-infra, /backup/proxmox-infra, /proxmox-infra"

always the same result. My understanding of NFSv4 shares is that you specify the "root-share" (in this case "/exports") on the
server-side and the client will only see shares within that root-share. And the client-side path shouldn't contain the root-share

So it would be lke this:

server-side            | client-side
/exports               | <host>:/
/exports/backup        | <host>:/backups
/exports/movies        | <host>:/movies

and every sub-folder on the server-side is either a "bind"-mount or a symlink to the real directory / filesystem.

But please enlighten me if this is wrong.

> command line nfsv4 mounts should work in any case

They didn't, though it might be that NFSv4 would need something else on the server-side that is not configured / running.

My problem is now solved with allowing upd/111 for showmount and using NFSv3. But this solution is a bit unsatisfying.

> _______________________________________________
> pve-user mailing list
> pve-user at pve.proxmox.com
> https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user

More information about the pve-user mailing list