[PVE-User] DHCP on bridge interface

Vadim Bulst vadim.bulst at bbz.uni-leipzig.de
Tue Jan 24 13:21:56 CET 2017


Sorry - my fault. Everything is like it should. My puppet-module was 
delivering the wrong file.


Am 24.01.2017 um 07:50 schrieb Vadim Bulst:
> Hi there,
>
> I'd like to use DHCP-Address configation on my bridged network interfaces
>
> /etc/network/interfaces which i'd like to use:
>
> auto lo
> iface lo inet loopback
>
> iface eth4 inet manual
>
> iface eth5 inet manual
>
> auto bond0
> iface bond0 inet manual
>         slaves eth4 eth5
>         bond_miimon 100
>         bond_mode 802.3ad
>         mtu 9100
>
>
> auto vmbr0
> iface vmbr0 inet dhcp
>                bridge_ports bond0
>                bridge_stp off
>                bridge_fd 0
>                bridge_vlan_aware yes
>
> When i reboot the server all options of the bridge are gone ( 
> commented out ) and no address lease is received. Even if i put this 
> config to /etc/network/interfaces.new . In the Debian-Wiki it is 
> written that it should be possible to configure a bridge using dhcp:
>
> https://wiki.debian.org/BridgeNetworkConnections :
>
> "
>
>  # This file describes the network interfaces available on your system
>  # and how to activate them. For more information, see interfaces(5).
>
>  # The loopback network interface
>  auto lo br0
>  iface lo inet loopback
>
>  # Set up interfaces manually, avoiding conflicts with, e.g., network 
> manager
>  iface eth0 inet manual
>
>  iface eth1 inet manual
>
>  # Bridge setup
>  iface br0 inet dhcp
>     bridge_ports eth0 eth1
>
> "
>
> Our Cisco-Engineer wants to keep the switch configuration flexible in 
> terms of MTU. That's why we'd like to use dhcp on the bridging 
> interfaces.
>
> Any suggestions to this phenomena?
>
> Cheers,
>
> Vadim
>
> _______________________________________________
> pve-user mailing list
> pve-user at pve.proxmox.com
> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user


More information about the pve-user mailing list