[PVE-User] Failure to install latest PVE on Debian Stretch

Mikhail m at plus-plus.su
Mon Dec 18 18:57:23 CET 2017


Hello,

Following this official wiki instruction:
https://pve.proxmox.com/wiki/Install_Proxmox_VE_on_Debian_Stretch

(done that procedure several times already)

I'm having problem with new server. It is running clean install of
Debian Stretch and I'm trying to put Proxmox using PVE packages install
as described in wiki. I'm not sure whether the problem is related to
something misconfigured on Stretch itself, or the problem is somewhere
with PVE packages, but my installation fails on the following:

Setting up pve-firewall (3.0-5) ...
Created symlink
/etc/systemd/system/multi-user.target.wants/pve-firewall.service →
/lib/systemd/system/pve-firewall.service.
insserv: Service pve-cluster has to be enabled to start service pvefw-logger
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package pve-firewall (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of qemu-server:
 qemu-server depends on pve-firewall; however:
  Package pve-firewall is not configured yet.

dpkg: error processing package qemu-server (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of proxmox-ve:
 proxmox-ve depends on qemu-server; however:
  Package qemu-server is not configured yet.

dpkg: error processing package proxmox-ve (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pve-manager:
 pve-manager depends on pve-firewall; however:
  Package pve-firewall is not configured yet.
 pve-manager depends on qemu-server (>= 1.1-1); however:
  Package qemu-server is not configured yet.

dpkg: error processing package pve-manager (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pve-ha-manager:
 pve-ha-manager depends on qemu-server; however:
  Package qemu-server is not configured yet.

dpkg: error processing package pve-ha-manager (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pve-container:
 pve-container depends on pve-ha-manager; however:
  Package pve-ha-manager is not configured yet.

dpkg: error processing package pve-container (--configure):
 dependency problems - leaving unconfigured
Processing triggers for initramfs-tools (0.130) ...
update-initramfs: Generating /boot/initrd.img-4.13.13-1-pve
I: The initramfs will attempt to resume from /dev/md0
I: (UUID=25b05adb-f12d-40d0-8c68-1bf28e25e9ba)
I: Set the RESUME variable to override this.
Processing triggers for libc-bin (2.24-11+deb9u1) ...
Processing triggers for systemd (232-25+deb9u1) ...
Errors were encountered while processing:
 pve-firewall
 qemu-server
 proxmox-ve
 pve-manager
 pve-ha-manager
 pve-container
E: Sub-process /usr/bin/dpkg returned an error code (1)
root at pve /etc/apt/sources.list.d #



I have tried everything, "apt-get -f install", dpkg-reconfigure all PVE
packages, remove proxmox-ve postfix open-iscsi packages and doing
install again - always failing with the same error.

Has anyone else experienced something similar? This has never failed on
my history before.

Thanks.


More information about the pve-user mailing list