[PVE-User] WARNING: Upgrade and Watchdog kills Server in HA-Mode

Andreas Herrmann andreas at mx20.org
Wed Dec 6 18:43:46 CET 2017


Hi there,

be warned: the actual update may reboot your server if in HA-Mode. It happened
on 2 of 5 servers!

The following packages will be upgraded:
   libpve-common-perl (5.0-20 => 5.0-22)
   libpve-http-server-perl (2.0-6 => 2.0-7)
   libpve-storage-perl (5.0-16 => 5.0-17)
   lxc-pve (2.1.0-2 => 2.1.1-2)
   lxcfs (2.0.7-pve4 => 2.0.8-1)
   pve-cluster (5.0-15 => 5.0-17)
   pve-firewall (3.0-3 => 3.0-4)
   pve-ha-manager (2.0-3 => 2.0-4)
   pve-manager (5.1-36 => 5.1-38)
   pve-qemu-kvm (2.9.1-2 => 2.9.1-3)
   spiceterm (3.0-4 => 3.0-5)
   vncterm (1.5-2 => 1.5-3)


Installing new version of config file /etc/rc.d/init.d/lxcfs ...
Processing triggers for man-db (2.7.6.1-2) ...
Setting up pve-cluster (5.0-17) ...
Removing obsolete conffile /etc/default/pve-cluster ...
Setting up pve-firewall (3.0-4) ...
Setting up lxc-pve (2.1.1-2) ...
Installing new version of config file
/etc/apparmor.d/abstractions/lxc/container-base ...
Setting up libpve-http-server-perl (2.0-7) ...
Setting up libpve-storage-perl (5.0-17) ...
Setting up pve-ha-manager (2.0-4) ...
watchdog-mux.service is a disabled or a static unit, not starting it.
Setting up pve-manager (5.1-38) ...
Installing new version of config file /etc/logrotate.d/pve ...
....
REBOOT


root at nethcn-b1:~# apt-get upgrade
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to
correct the problem.
root at nethcn-b1:~# dpkg --configure -a
Setting up pve-manager (5.1-38) ...
Processing triggers for libc-bin (2.24-11+deb9u1) ...


Andreas


More information about the pve-user mailing list