Marcel van Leeuwen mavleeuwen at icloud.com
Sat Nov 19 14:35:52 CET 2016


I’m trying to mount a remote NFS share (NAS) from a LXC container. I found this on the Proxmox forums and tried it. 


# Do not load this file.  Rather, load /etc/apparmor.d/lxc-containers, which
# will source all profiles under /etc/apparmor.d/lxc

profile lxc-container-default-with-nfs flags=(attach_disconnected,mediate_deleted) {
  #include <abstractions/lxc/container-base>

# allow NFS (nfs/nfs4) mounts.
  mount fstype=nfs*,


apparmor_parser -r /etc/apparmor.d/lxc-containers

add to container config

lxc.aa_profile: lxc-container-default-with-nfs

I add the above settings to my Proxmox host but when I restart the LXC container with the new settings I can’t access the web app in this container anymore. It looks like all network connectivity is gone. Also tried to ping Goolge.com <http://goolge.com/> within the LXC container but no go. When I remove  

lxc.aa_profile: lxc-container-default-with-nfs

everything is okay. Any idea?



More information about the pve-user mailing list