[PVE-User] Cannot boot on a Windows 7 VM from a full-cloned template

Dominik Csapak d.csapak at proxmox.com
Thu Mar 17 16:24:00 CET 2016


could you maybe send your configuration of the template?

(should be under /etc/pve/qemu/106.conf)

I can reproduce the issue, but only when the cache mode of the disk is writeback
or writeback(unsafe)


> On March 16, 2016 at 7:15 PM Gaël Jobin <gael.jobin at switzerlandmail.ch> wrote:
>     Hi all,
>     I'm using Proxmox with the testing repo.
>     I successfully installed a Windows 7 VM and made a template of it. Then, I
> tried to create a new VM by cloning the previous template (full clone).
> Unfortunately, the new VM cannot boot Windows. On the other hand, with a
> "linked-clone", it works fine.
>     I noticed that the cloning was internally doing a "qemu-img convert". More
> precisely in my case, "/usr/bin/qemu-img convert -p -f raw -O raw
> /var/lib/vz/images/106/base-106-disk-1.raw
> /var/lib/vz/images/109/vm-109-disk-1.raw".
>     I did the same command manually and was quiet surprised to see that the
> new disk has the exact same size but not the same MD5 hash (md5sum command).
>     Any idea why qemu-img corrupt the disk?
>     For the moment, I just manually "cp" the base disk to my newly created VM
> directory and it's working. Also, I tried to convert the base disk from raw to
> qcow2 and back qcow2 to raw and the new raw disk is booting fine ! The problem
> seems related to "raw to raw" conversion...
>     qemu-img version 2.5.0pve-qemu-kvm_2.5-9
>     Thank you for your help,
>     Regards,
>     Gaël


> _______________________________________________
>     pve-user mailing list
>     pve-user at pve.proxmox.com
>     http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.proxmox.com/pipermail/pve-user/attachments/20160317/36c4bb65/attachment.htm>

More information about the pve-user mailing list