[PVE-User] [v4.1] Ceph Server and systemd

Eneko Lacunza elacunza at binovo.es
Mon Jan 25 16:08:59 CET 2016

Hi all,

This weekend osd.8 of our 9-osd ceph/proxmox v4.1 cluster went down. It 
seems there was some kind of error with the RAID disk controller, but 
that's another issue (server is fine right know thanks ;)  ).

This morning I've tried to restart osd.8 from the cli . Looking around 
it seemed that the correct command was:

systemctl start ceph-osd at 8

But it hasn't worked:
# /etc/init.d/ceph start osd.8
[ ok ] Starting ceph (via systemctl): ceph.service.
root at camelot:~# systemctl start ceph-osd at 8
Failed to start ceph-osd at 8.service: Unit ceph-osd at 8.service failed to 
load: No such file or directory.
root at camelot:~# systemctl status ceph-osd at 8ceph-osd at 8.service
    Loaded: not-found (Reason: No such file or directory)
    Active: inactive (dead)

I was able to restart osd.8 from Proxmox GUI though (extra points for 
Proxmox Ceph Server!)

Now, if I check services in systemd:

# systemctl|grep ceph-osd
var-lib-ceph-osd-ceph\x2d1.mount loaded active mounted   
var-lib-ceph-osd-ceph\x2d3.mount loaded active mounted   
var-lib-ceph-osd-ceph\x2d8.mount loaded active mounted   
run-30379.service loaded active running   /bin/bash -c ulimit -n 32768; 
/usr/bin/ceph-osd -i 8 --pid-file /var/run/ceph/osd.8.pid -c 
/etc/pve/ceph.conf --cluster ceph -f
run-3134.service loaded active running   /bin/bash -c ulimit -n 32768; 
/usr/bin/ceph-osd -i 3 --pid-file /var/run/ceph/osd.3.pid -c 
/etc/ceph/ceph.conf --cluster ceph -f
run-3368.service loaded active running   /bin/bash -c ulimit -n 32768; 
/usr/bin/ceph-osd -i 1 --pid-file /var/run/ceph/osd.1.pid -c 
/etc/ceph/ceph.conf --cluster ceph -f
run-3609.service loaded active exited    /bin/bash -c ulimit -n 32768; 
/usr/bin/ceph-osd -i 8 --pid-file /var/run/ceph/osd.8.pid -c 
/etc/ceph/ceph.conf --cluster ceph -f

I'm not yet very comfortable with systemd, but it doesn't seem a good 
state, as there are 2 osd.8 services now? And the osd.8 service started 
from GUI has slightly different command line, altough it should be OK AFAIK.

What is the correct CLI command to start/stop Ceph daemons?

Thanks for your suggestions...


Zuzendari Teknikoa / Director Técnico
Binovo IT Human Project, S.L.
Telf. 943575997
Astigarraga bidea 2, planta 6 dcha., ofi. 3-2; 20180 Oiartzun (Gipuzkoa)

More information about the pve-user mailing list