[PVE-User] Message from PVE-HA-CRM

Gilberto Nunes gilberto.nunes32 at gmail.com
Fri Feb 5 14:49:57 CET 2016


Sure! Many month ago I did it...

Thanks

2016-02-05 11:41 GMT-02:00 David Lawley <davel at upilab.com>:

> did you stop the VM before you disabled HA?
>
> On 2/5/2016 7:56 AM, Gilberto Nunes wrote:
>
>> And the stop from time to time... Last time was about two weeks ago...
>>
>> 2016-02-05 10:39 GMT-02:00 Gilberto Nunes <gilberto.nunes32 at gmail.com
>> <mailto:gilberto.nunes32 at gmail.com>>:
>>
>>     Sorry... I don'e mention it, but now, I have just one node and had
>>     disable the HA for that VM... There's no other VM.... Just one, with
>>     HA disable...
>>
>>     BTW, here the outputs...
>>
>>     # systemctl status pve-ha-lrm
>>
>>     systemctl status pve-ha-lrm
>>     ● pve-ha-lrm.service - PVE Local HA Ressource Manager Daemon
>>         Loaded: loaded (/lib/systemd/system/pve-ha-lrm.service; enabled)
>>         Active: active (running) since Wed 2016-01-20 08:12:07 BRST; 2
>>     weeks 2 days ago
>>       Main PID: 1900 (pve-ha-lrm)
>>         CGroup: /system.slice/pve-ha-lrm.service
>>                 └─1900 pve-ha-lrm
>>
>>     Jan 20 08:12:07 proxmox01 pve-ha-lrm[1900]: starting server
>>     Jan 20 08:12:07 proxmox01 pve-ha-lrm[1900]: status change startup =>
>>     wait_for_agent_lock
>>
>>
>>     # ha-manager status
>>
>>     ha-manager status
>>     quorum OK
>>     master proxmox01 (active, Fri Feb  5 10:37:56 2016)
>>     lrm proxmox01 (active, Fri Feb  5 10:38:02 2016)
>>
>>     And the log attached
>>
>>     Thanks a lot
>>
>>
>>
>>
>>
>>     2016-02-05 10:15 GMT-02:00 Thomas Lamprecht <t.lamprecht at proxmox.com
>>     <mailto:t.lamprecht at proxmox.com>>:
>>
>>
>>         Hi,
>>
>>         the obvious questions: what did you do before the error came to
>>         light?
>>
>>         With this error the HA CRM cannot do any action (start, stop,
>>         migrate, ...)
>>
>>         whats the output from
>>
>>         # systemctl status pve-ha-lrm
>>
>>         # ha-manager status
>>
>>         on this node (or both nodes), be sure that pve-ha-lrm is started!
>>
>>         Also if no obvious error is visible please append the logs with:
>>
>>         # journalctl -u pve-ha-lrm -u pve-ha-crm
>>
>>         You can redirect the output to an file and if yo
>>
>>         journalctl -u pve-ha-lrm -u pve-ha-crm > out.log
>>
>>
>>
>>         On 02/05/2016 01:04 PM, Gilberto Nunes wrote:
>>
>>>         Hello list
>>>
>>>         In the past, I had a cluster with two nodes plus storage with
>>>         HA enabled...
>>>         About 3 month, I note that the VM just stop, from nothing at
>>>         all....
>>>         The PVE remain alive and storage too...
>>>
>>>         I get this message in syslog:
>>>
>>>         Feb  4 19:15:42 proxmox01 pve-ha-crm[1894]: got unexpected
>>>         error - can't open '/etc/pve/nodes/proxmox01/lrm_status' - No
>>>         such file or directory
>>>         Feb  4 19:16:12 proxmox01 pve-ha-crm[1894]: got unexpected
>>>         error - can't open '/etc/pve/nodes/proxmox01/lrm_status' - No
>>>         such file or directory
>>>         Feb  4 19:16:32 proxmox01 pve-ha-crm[1894]: got unexpected
>>>         error - can't open '/etc/pve/nodes/proxmox01/lrm_status' - No
>>>         such file or directory
>>>         Feb  4 19:16:52 proxmox01 pve-ha-crm[1894]: got unexpected
>>>         error - can't open '/etc/pve/nodes/proxmox01/lrm_status' - No
>>>         such file or directory
>>>         Feb  4 19:17:12 proxmox01 pve-ha-crm[1894]: got unexpected
>>>         error - can't open '/etc/pve/nodes/proxmox01/lrm_status' - No
>>>         such file or directory
>>>         Feb  4 22:27:52 proxmox01 pve-ha-crm[1894]: got unexpected
>>>         error - can't open '/etc/pve/nodes/proxmox01/lrm_status' - No
>>>         such file or directory
>>>         Feb  4 22:28:02 proxmox01 pve-ha-crm[1894]: got unexpected
>>>         error - can't open '/etc/pve/nodes/proxmox01/lrm_status' - No
>>>         such file or directory
>>>
>>>         That's would be the reason for VM stoped???
>>>
>>>
>>>
>>>
>>>         _______________________________________________
>>>         pve-user mailing list
>>>         pve-user at pve.proxmox.com <mailto:pve-user at pve.proxmox.com>
>>>         http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
>>>
>>
>>
>>         _______________________________________________
>>         pve-user mailing list
>>         pve-user at pve.proxmox.com <mailto:pve-user at pve.proxmox.com>
>>         http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
>>
>>
>>
>>
>>     --
>>
>>     Gilberto Ferreira
>>     +55 (47) 9676-7530 <tel:%2B55%20%2847%29%209676-7530>
>>     Skype: gilberto.nunes36
>>
>>
>>
>>
>> --
>>
>> Gilberto Ferreira
>> +55 (47) 9676-7530
>> Skype: gilberto.nunes36
>>
>>
>>
>> _______________________________________________
>> pve-user mailing list
>> pve-user at pve.proxmox.com
>> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
>>
>>
> _______________________________________________
> pve-user mailing list
> pve-user at pve.proxmox.com
> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
>



-- 

Gilberto Ferreira
+55 (47) 9676-7530
Skype: gilberto.nunes36
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20160205/8f34ae12/attachment-0015.html>


More information about the pve-user mailing list