[PVE-User] Message from PVE-HA-CRM

Gilberto Nunes gilberto.nunes32 at gmail.com
Fri Feb 5 13:39:11 CET 2016


Sorry... I don'e mention it, but now, I have just one node and had disable
the HA for that VM... There's no other VM.... Just one, with HA disable...

BTW, here the outputs...

# systemctl status pve-ha-lrm

systemctl status pve-ha-lrm
● pve-ha-lrm.service - PVE Local HA Ressource Manager Daemon
   Loaded: loaded (/lib/systemd/system/pve-ha-lrm.service; enabled)
   Active: active (running) since Wed 2016-01-20 08:12:07 BRST; 2 weeks 2
days ago
 Main PID: 1900 (pve-ha-lrm)
   CGroup: /system.slice/pve-ha-lrm.service
           └─1900 pve-ha-lrm

Jan 20 08:12:07 proxmox01 pve-ha-lrm[1900]: starting server
Jan 20 08:12:07 proxmox01 pve-ha-lrm[1900]: status change startup =>
wait_for_agent_lock


# ha-manager status

ha-manager status
quorum OK
master proxmox01 (active, Fri Feb  5 10:37:56 2016)
lrm proxmox01 (active, Fri Feb  5 10:38:02 2016)

And the log attached

Thanks a lot





2016-02-05 10:15 GMT-02:00 Thomas Lamprecht <t.lamprecht at proxmox.com>:

> Hi,
>
> the obvious questions: what did you do before the error came to light?
>
> With this error the HA CRM cannot do any action (start, stop, migrate, ...)
>
> whats the output from
>
> # systemctl status pve-ha-lrm
>
> # ha-manager status
>
> on this node (or both nodes), be sure that pve-ha-lrm is started!
>
> Also if no obvious error is visible please append the logs with:
>
> # journalctl -u pve-ha-lrm -u pve-ha-crm
>
> You can redirect the output to an file and if yo
>
> journalctl -u pve-ha-lrm -u pve-ha-crm > out.log
>
>
>
> On 02/05/2016 01:04 PM, Gilberto Nunes wrote:
>
> Hello list
>
> In the past, I had a cluster with two nodes plus storage with HA enabled...
> About 3 month, I note that the VM just stop, from nothing at all....
> The PVE remain alive and storage too...
>
> I get this message in syslog:
>
> Feb  4 19:15:42 proxmox01 pve-ha-crm[1894]: got unexpected error - can't
> open '/etc/pve/nodes/proxmox01/lrm_status' - No such file or directory
> Feb  4 19:16:12 proxmox01 pve-ha-crm[1894]: got unexpected error - can't
> open '/etc/pve/nodes/proxmox01/lrm_status' - No such file or directory
> Feb  4 19:16:32 proxmox01 pve-ha-crm[1894]: got unexpected error - can't
> open '/etc/pve/nodes/proxmox01/lrm_status' - No such file or directory
> Feb  4 19:16:52 proxmox01 pve-ha-crm[1894]: got unexpected error - can't
> open '/etc/pve/nodes/proxmox01/lrm_status' - No such file or directory
> Feb  4 19:17:12 proxmox01 pve-ha-crm[1894]: got unexpected error - can't
> open '/etc/pve/nodes/proxmox01/lrm_status' - No such file or directory
> Feb  4 22:27:52 proxmox01 pve-ha-crm[1894]: got unexpected error - can't
> open '/etc/pve/nodes/proxmox01/lrm_status' - No such file or directory
> Feb  4 22:28:02 proxmox01 pve-ha-crm[1894]: got unexpected error - can't
> open '/etc/pve/nodes/proxmox01/lrm_status' - No such file or directory
>
> That's would be the reason for VM stoped???
>
>
>
>
> _______________________________________________
> pve-user mailing listpve-user at pve.proxmox.comhttp://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
>
>
>
> _______________________________________________
> pve-user mailing list
> pve-user at pve.proxmox.com
> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
>
>


-- 

Gilberto Ferreira
+55 (47) 9676-7530
Skype: gilberto.nunes36
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20160205/4f126976/attachment-0015.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: error.log
Type: text/x-log
Size: 21135 bytes
Desc: not available
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20160205/4f126976/attachment-0015.bin>


More information about the pve-user mailing list