[PVE-User] Online migration problem

Eneko Lacunza elacunza at binovo.es
Thu Feb 25 12:45:23 CET 2016


Hi all,

I'm in the process of patching our office 4-node Proxmox cluster. It 
seems I'm unable to online migrate VMs between the newest PVE version 
and our previous installed versions:

node1, node4: (updated nodes)
# pveversion -v
proxmox-ve: 4.1-37 (running kernel: 4.2.6-1-pve)
pve-manager: 4.1-13 (running version: 4.1-13/cfb599fb)
pve-kernel-2.6.32-37-pve: 2.6.32-150
pve-kernel-2.6.32-42-pve: 2.6.32-165
pve-kernel-4.2.6-1-pve: 4.2.6-36
pve-kernel-2.6.32-43-pve: 2.6.32-166
pve-kernel-4.2.8-1-pve: 4.2.8-37
pve-kernel-2.6.32-39-pve: 2.6.32-157
pve-kernel-2.6.32-34-pve: 2.6.32-140
pve-kernel-2.6.32-40-pve: 2.6.32-160
lvm2: 2.02.116-pve2
corosync-pve: 2.3.5-2
libqb0: 1.0-1
pve-cluster: 4.0-32
qemu-server: 4.0-55
pve-firmware: 1.1-7
libpve-common-perl: 4.0-48
libpve-access-control: 4.0-11
libpve-storage-perl: 4.0-40
pve-libspice-server1: 0.12.5-2
vncterm: 1.2-1
pve-qemu-kvm: 2.5-5
pve-container: 1.0-44
pve-firewall: 2.0-17
pve-ha-manager: 1.0-21
ksm-control-daemon: 1.2-1
glusterfs-client: 3.5.2-2+deb8u1
lxc-pve: 1.1.5-7
lxcfs: 0.13-pve3
cgmanager: 0.39-pve1
criu: 1.6.0-1

node2, node3: (not updated)
# pveversion -v
proxmox-ve: 4.1-32 (running kernel: 4.2.6-1-pve)
pve-manager: 4.1-4 (running version: 4.1-4/ccba54b0)
pve-kernel-2.6.32-37-pve: 2.6.32-150
pve-kernel-2.6.32-42-pve: 2.6.32-165
pve-kernel-4.2.6-1-pve: 4.2.6-32
pve-kernel-2.6.32-32-pve: 2.6.32-136
pve-kernel-2.6.32-43-pve: 2.6.32-166
pve-kernel-2.6.32-39-pve: 2.6.32-157
pve-kernel-4.2.2-1-pve: 4.2.2-16
lvm2: 2.02.116-pve2
corosync-pve: 2.3.5-2
libqb0: 0.17.2-1
pve-cluster: 4.0-30
qemu-server: 4.0-44
pve-firmware: 1.1-7
libpve-common-perl: 4.0-43
libpve-access-control: 4.0-11
libpve-storage-perl: 4.0-38
pve-libspice-server1: 0.12.5-2
vncterm: 1.2-1
pve-qemu-kvm: 2.4-20
pve-container: 1.0-37
pve-firewall: 2.0-15
pve-ha-manager: 1.0-16
ksm-control-daemon: 1.2-1
glusterfs-client: 3.5.2-2+deb8u1
lxc-pve: 1.1.5-5
lxcfs: 0.13-pve3
cgmanager: 0.39-pve1
criu: 1.6.0-1
fence-agents-pve: not correctly installed

I can online migrate VMs:
     node1<->node4
     node2<->node3
but can't do
     node1<->node2
     node4<->node2
     node1<->node3
     node4<->node3

Reported log:
Feb 25 12:38:38 starting migration of VM 119 to node 'sanmarko' 
(172.29.37.4) Feb 25 12:38:38 copying disk images Feb 25 12:38:38 
starting VM 119 on remote node 'sanmarko' Feb 25 12:38:39 starting ssh 
migration tunnel Feb 25 12:38:39 starting online/live migration on 
localhost:60000 Feb 25 12:38:39 migrate_set_speed: 8589934592 Feb 25 
12:38:39 migrate_set_downtime: 0.1 Feb 25 12:38:41 ERROR: online migrate 
failure - aborting Feb 25 12:38:41 aborting phase 2 - cleanup resources 
Feb 25 12:38:41 migrate_cancel Feb 25 12:38:43 ERROR: migration finished 
with problems (duration 00:00:05) TASK ERROR: migration problems
Offline migration works OK.
I have also tried to upgrade a node (node4) and then migrate to node1, 
but it hasn't worked, until I have stopped and restarted the VM.

Is this expected? How should I upgrade without VM downtime?

Thanks
Eneko

-- 
Zuzendari Teknikoa / Director T├ęcnico
Binovo IT Human Project, S.L.
Telf. 943493611
       943324914
Astigarraga bidea 2, planta 6 dcha., ofi. 3-2; 20180 Oiartzun (Gipuzkoa)
www.binovo.es

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20160225/6f5c525f/attachment-0014.html>


More information about the pve-user mailing list