[PVE-User] Proxmox 4.0 cluster issue

Guy Plunkett guy at britewhite.net
Tue Feb 16 19:46:09 CET 2016


Hello,

I’ve upgraded my Dell M1000 blade centre to Proxmox 4.1. The upgrade seems to go fine, however I can’t seem to have all 4 nodes connected at once.  It seems to work for a short time then then one node will disappear,  I can SSH to it just fine, and have to restart corosync and pve-cluster and it will join again, however shortly later another node will disappear.

Finally a node crashes and restarts. There is nothing present in the syslogs as to why this node cashed.

I’ve spent 2 days fighting with this to try and resolve it.  This was working just fine on 3.x.

Please can someone help here I’m pulling my hair out trying to get this working, and I don’t have much left!

Cheers,
—Guy

Feb 16 16:32:50 proxmox01 corosync[5747]:  [TOTEM ] A new membership (10.240.0.100:35536) was formed. Members
Feb 16 16:32:50 proxmox01 corosync[5747]:  [QUORUM] Members[3]: 4 3 2
Feb 16 16:32:50 proxmox01 corosync[5747]:  [MAIN  ] Completed service synchronization, ready to provide service.
Feb 16 16:32:53 proxmox01 corosync[5747]:  [TOTEM ] A new membership (10.240.0.100:35540) was formed. Members
Feb 16 16:32:53 proxmox01 corosync[5747]:  [QUORUM] Members[3]: 4 3 2
Feb 16 16:32:53 proxmox01 corosync[5747]:  [MAIN  ] Completed service synchronization, ready to provide service.
Feb 16 16:32:56 proxmox01 corosync[5747]:  [TOTEM ] A new membership (10.240.0.100:35544) was formed. Members
Feb 16 16:32:56 proxmox01 corosync[5747]:  [QUORUM] Members[3]: 4 3 2
Feb 16 16:32:56 proxmox01 corosync[5747]:  [MAIN  ] Completed service synchronization, ready to provide service.
Feb 16 16:32:59 proxmox01 corosync[5747]:  [TOTEM ] A new membership (10.240.0.100:35548) was formed. Members
Feb 16 16:32:59 proxmox01 corosync[5747]:  [QUORUM] Members[3]: 4 3 2
Feb 16 16:32:59 proxmox01 corosync[5747]:  [MAIN  ] Completed service synchronization, ready to provide service.
Feb 16 16:33:02 proxmox01 corosync[5747]:  [TOTEM ] A new membership (10.240.0.100:35552) was formed. Members
Feb 16 16:33:02 proxmox01 corosync[5747]:  [QUORUM] Members[3]: 4 3 2
Feb 16 16:33:02 proxmox01 corosync[5747]:  [MAIN  ] Completed service synchronization, ready to provide service.
Feb 16 16:33:05 proxmox01 corosync[5747]:  [TOTEM ] A new membership (10.240.0.100:35556) was formed. Members
Feb 16 16:33:05 proxmox01 corosync[5747]:  [QUORUM] Members[3]: 4 3 2
Feb 16 16:33:05 proxmox01 corosync[5747]:  [MAIN  ] Completed service synchronization, ready to provide service.
Feb 16 16:33:08 proxmox01 corosync[5747]:  [TOTEM ] A new membership (10.240.0.100:35560) was formed. Members
Feb 16 16:33:08 proxmox01 corosync[5747]:  [QUORUM] Members[3]: 4 3 2
Feb 16 16:33:08 proxmox01 corosync[5747]:  [MAIN  ] Completed service synchronization, ready to provide service.
Feb 16 16:33:11 proxmox01 corosync[5747]:  [TOTEM ] A new membership (10.240.0.100:35564) was formed. Members
Feb 16 16:33:11 proxmox01 corosync[5747]:  [QUORUM] Members[3]: 4 3 2
Feb 16 16:33:11 proxmox01 corosync[5747]:  [MAIN  ] Completed service synchronization, ready to provide service.
Feb 16 16:36:45 proxmox01 rsyslogd: [origin software="rsyslogd" swVersion="8.4.2" x-pid="2723" x-info="http://www.rsyslog.com <http://www.rsyslog.com/>"] start
Feb 16 16:36:45 proxmox01 systemd-modules-load[999]: Module 'fuse' is builtin
Feb 16 16:36:45 proxmox01 systemd-modules-load[999]: Inserted module 'vhost_net'
Feb 16 16:36:45 proxmox01 hdparm[1031]: Setting parameters of disc: (none).
Feb 16 16:36:45 proxmox01 lvm[1280]: 3 logical volume(s) in volume group "pve" now active



# cat /etc/cluster/cluster.conf 
<?xml version="1.0"?>
<cluster name="Cork-Training" config_version="6">

  <cman keyfile="/var/lib/pve-cluster/corosync.authkey">
  </cman>

  <clusternodes>
  <clusternode name="proxmox01" votes="1" nodeid="1"/>
  <clusternode name="proxmox02" votes="1" nodeid="2"/><clusternode name="proxmox03" votes="1" nodeid="3"/><clusternode name="proxmox04" votes="1" nodeid="4"/></clusternodes>

</cluster>

# cat /etc/pve/corosync.conf 
logging {
  debug: off
  to_syslog: yes
}

nodelist {
  node {
    name: proxmox04
    nodeid: 1
    quorum_votes: 1
    ring0_addr: proxmox04
  }

  node {
    name: proxmox03
    nodeid: 2
    quorum_votes: 1
    ring0_addr: proxmox03
  }

  node {
    name: proxmox02
    nodeid: 3
    quorum_votes: 1
    ring0_addr: proxmox02
  }

  node {
    name: proxmox01
    nodeid: 4
    quorum_votes: 1
    ring0_addr: proxmox01
  }

}

quorum {
  provider: corosync_votequorum
}

totem {
  cluster_name: Cork-Training
  config_version: 6
  ip_version: ipv4
  secauth: on
  version: 2
  interface {
    bindnetaddr: 10.240.0.100
    ringnumber: 0
  }

}




----
Guy



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20160216/615d97fb/attachment-0014.html>


More information about the pve-user mailing list