[PVE-User] Bug in Cache options ZFS over ISCSI?

Michael Rasmussen mir at miras.org
Wed Sep 2 23:45:08 CEST 2015


On Wed, 2 Sep 2015 14:53:47 +0200
"Steffen Wagner" <mail at steffenwagner.com> wrote:

> 
> I am using nappit and Proxmox for ZFS over ISCSI.
> 
> When I create a VM and set writeback cache, the option inside napp it is
> correctly set.. but if I change it later to none or again back, the values
> are not transmitted to nappit.
> 
>  
You are mixing to different options. Cache can be configured both on
iSCSI level and on VM level. Cache on iSCSI level is configured on a
storage basis (storage view in Proxmox) which means this setting is
affecting all new VM's while cache on the VM level is affecting only
the specific VM. What you can see in napp-it is the cache setting on
iSCSI level while the cache setting on VM level is only used as an
option when starting the VM in proxmox.

I hope the above explanation makes sense?

-- 
Hilsen/Regards
Michael Rasmussen

Get my public GnuPG keys:
michael <at> rasmussen <dot> cc
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xD3C9A00E
mir <at> datanom <dot> net
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xE501F51C
mir <at> miras <dot> org
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xE3E80917
--------------------------------------------------------------
/usr/games/fortune -es says:
HOW YOU CAN TELL THAT IT'S GOING TO BE A ROTTEN DAY:
	#15 Your pet rock snaps at you.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 181 bytes
Desc: OpenPGP digital signature
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20150902/dd579e38/attachment-0015.sig>


More information about the pve-user mailing list