[PVE-User] PVE 4 and problem with drbdmanage

Gilberto Nunes gilberto.nunes32 at gmail.com
Fri Sep 11 16:05:20 CEST 2015


Hi all...

I deploy two servers here, with PVE 4 and DRBD9.
Same days ago, I was able to install and perform same live migration.
Now,I can do it anymore...
I deploy a new VM with Windows XP, just for test but I can't migrate...
I get this error:

Sep 11 10:57:03 starting migration of VM 101 to node 'pve02' (10.0.0.2)
Sep 11 10:57:03 copying disk images
Sep 11 10:57:03 starting VM 101 on remote node 'pve02'
Sep 11 10:57:03 drbd error: Object not found
Sep 11 10:57:03 ERROR: online migrate failure - command '/usr/bin/ssh -o
'BatchMode=yes' root at 10.0.0.2 qm start 101 --stateuri tcp --skiplock
--migratedfrom pve01 --machine pc-i440fx-2.4' failed: exit code 255
Sep 11 10:57:03 aborting phase 2 - cleanup resources
Sep 11 10:57:03 migrate_cancel
Sep 11 10:57:04 ERROR: migration finished with problems (duration 00:00:01)
TASK ERROR: migration problems

In pve01 I see this:

pve01:~# drbdmanage list-volumes
+------------------------------------------------------------------------------------------------------------+

| Name          | Vol ID |  Size | Minor |
                                                          | State |
+------------------------------------------------------------------------------------------------------------+

| vm-101-disk-1 |      0 | 32768 |    11 |
                                                          |    ok |
+------------------------------------------------------------------------------------------------------------+

In pve02 I see this:

pve02:~# drbdmanage list-volumes
+------------------------------------------------------------------------------------------------------------+

| Name          | Vol ID |  Size | Minor |
                                                          | State |
+------------------------------------------------------------------------------------------------------------+

| vm-100-disk-1 |      0 | 32768 |    10 |
                                                          |    ok |
+------------------------------------------------------------------------------------------------------------+


As can you see, the disc 101 exist in PVE01 but not in PVE02.
How can I force drbdmanage to sync or whatever to show disc 101 in both
servers??

Thanks
-- 

Gilberto Ferreira
+55 (47) 9676-7530
Skype: gilberto.nunes36
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20150911/a6161132/attachment-0014.html>


More information about the pve-user mailing list