[PVE-User] Losing quorum - cluster broken

Nicolas Costes nicolas.costes at univ-nantes.fr
Thu May 21 18:09:48 CEST 2015

> > We had a similar issues when we upgraded a few months ago... we had to
> > enable a multicast querier on the switch and everything started working
> > again.

> I tried to anable a multicast querier on the switch, no improvement.

And sooo... I was wrong. I read the switch's manual, I then *really* enabled a 
multicast querier and it seems to solve the issue. Cluster has been running 
now for 10 minutes without the help of promiscuous mode (it should have lost 
quorum in less than 5 minutes).

If it's still up tomorrow I will consider this as solved.

For those who experience the same problem, here is the procedure for a Dell 
5524 switch :

# configure
# bridge multicast filtering
# ip igmp snooping
# ip igmp snooping vlan VID
# ip igmp snooping vlan VID querier
# ip igmp snooping vlan VID querier address SWITCH_IP
# exit

VID is the relevant vlan ID and SWITCH_IP is the one the switch has has in 
this vlan.

To check : 

# show ip igmp snooping interface VID
# show ip igmp snooping groups

Nicolas Costes
Responsable de parc informatique
IUT de la Roche-sur-Yon
Université de Nantes
Tél.: 02 51 47 40 29

More information about the pve-user mailing list