[PVE-User] problem adding a graphics driver

David Rice David.Rice at imaginelearning.com
Thu Mar 26 00:05:21 CET 2015

I'm new here.  This problem has been raised before I'm sure.  If so, I'm sorry.  I couldn't find a search the archive button or capability.  If you could just point me to a solution I would really appreciate it.

I have run into a problem while using ProxMox.  It is amazing by the way.  When trying to run some software (which uses Unity player) on a Windows 7 VM, I get the following error:
Unity Web Player requires DX9 level graphics card.  Make sure you have graphics card drivers installed.

When I look at the Display Adapters installed in the Windows 7 VM it says I have:
Standard VGA Graphics Adapter
VNC Mirror Driver

When I try to update the Display driver(https://downloadcenter.intel.com/download/24329/Intel-HD-Graphics-Driver-for-7-8-8-1-64-bit)  first to Intel HD Graphics 4600 it gives me the following error:
This computer does not meet the minimum requirements for installing the software.

Additionally I need to add AMD Radeon HD 8790M driver after the Intel Driver has been installed.  Do you have any ideas?  I have been googling this for a while and trying lots of different things and thought that you might have some ideas.  Any information would be very helpful.

I have tried to update the /etc/pve/nodes/ilendtoend/qumu-server/100.conf file with the following:
hostpci0: 01:00.0

lspci output:
01:00.0 VGA compatibille controller: Advanced Micro Devices, Inc. [AMD/ATI] MARS XTX [Radeon HD 8790m]

pveversion output:
proxmox-ve-2.6.32: 3.3-147 (running kernel: 2.6.32-37-pve)

When I run the VM through the console I get the following monster error:

TASK ERROR: start failed: command '/usr/bin/kvm -id 102 -chardev 'socket,id=qmp,path=/var/run/qemu-server/102.qmp,server,nowait' -mon 'chardev=qmp,mode=control' -vnc unix:/var/run/qemu-server/102.vnc,x509,password -pidfile /var/run/qemu-server/102.pid -daemonize -smbios 'type=1,uuid=9132f203-4880-4926-abea-d95ffaf0e5d7' -name windows7 -smp '1,sockets=1,cores=1,maxcpus=1' -nodefaults -boot 'menu=on,strict=on,reboot-timeout=1000' -vga std -no-hpet -cpu 'kvm64,hv_spinlocks=0xffff,hv_relaxed,+lahf_lm,+x2apic,+sep' -m 2048 -k en-us -cpuunits 1000 -device 'piix3-usb-uhci,id=uhci,bus=pci.0,addr=0x1.0x2' -device 'usb-tablet,id=tablet,bus=uhci.0,port=1' -device 'pci-assign,host=01:00.0,id=hostpci0,bus=pci.0,addr=0x10' -device 'virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3' -iscsi 'initiator-name=iqn.1993-08.org.debian:01:3fc2e04b811f' -drive 'file=/var/lib/vz/template/iso/en_windows_7_enterprise_with_sp1_x64_dvd_u_677651.iso,if=none,id=drive-ide2,media=cdrom,aio=native' -device 'ide-cd,bus=ide.1,unit=0,drive=drive-ide2,id=ide2,bootindex=200' -drive 'file=/var/lib/vz/images/102/vm-102-disk-1.qcow2,if=none,id=drive-ide0,format=qcow2,aio=native,cache=none,detect-zeroes=on' -device 'ide-hd,bus=ide.0,unit=0,drive=drive-ide0,id=ide0,bootindex=100' -netdev 'type=tap,id=net0,ifname=tap102i0,script=/var/lib/qemu-server/pve-bridge,downscript=/var/lib/qemu-server/pve-bridgedown' -device 'e1000,mac=BE:AA:BD:0F:97:89,netdev=net0,bus=pci.0,addr=0x12,id=net0,bootindex=300' -rtc 'driftfix=slew,base=localtime' -global 'kvm-pit.lost_tick_policy=discard'' failed: exit code 1

Is there some magic I'm missing.  Again thank you for any help.

David Rice
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.proxmox.com/pipermail/pve-user/attachments/20150325/32e6ca29/attachment.htm>

More information about the pve-user mailing list