[PVE-User] implementing openvswitch

Sten Aus sten.aus at eenet.ee
Wed Jan 28 11:35:29 CET 2015


Hi

My cluster is almost green (only this ovs node is red), but GUI is working.

Output from nodeB (linux bridge). (Changed and sanitized some values)

cat /etc/pve/.members
{
"nodename": "nodeB",
"version": 32,
"cluster": { "name": "/greatcluster/", "version": 50, "nodes": /alot/, 
"quorate": 1 },
"nodelist": {
/  /output omitted//
*  "nodeB": { "id": 3, "online": 1, "ip": "***"},*
/  /output omitted/
/*  "nodewithOVS": { "id": 13, "online": 0},*
/  /output omitted//
   }
}

Output from nodewithOVS shows only this one node, no cluster information
cat /etc/pve/.members
{
"nodename": "*nodewithOVS*",
"version": 0
}

It's weird. I've only edited my interfaces file during this OVS-process. 
Now I've restored my old Linux bridge configuration, but still this node 
is red.
Maybe my OVS is correct and working but some configuration issue? This 
node has been switched off from cluster for about a week now.

On 28.01.15 10:09, Sten Aus wrote:
> Hi
>
> Thanks for your reply! I read your topic, but all MTUs are 1500, only 
> iscsi runs on MTU 9000.
>> Do you see any other indications that anything is failing in the 
>> cluster?  Things such as 'pvecm status' and 'clustat' - how do they 
>> output?  When looking in the web interface are you able to see and 
>> connect to all nodes?  Do they show a green or red status?
> They output very slowly, but finally they show everything is OK. 
> Cluster has quorum and all expected votes are completed.
> One thing that GUI almost crashes after I connect this ovs interface 
> to proxmox cluster. Everything is blank and login takes forever.
>> I had one node configured with OVS and the other without and they 
>> were able to talk for me without issue. My problem came down to an 
>> MTU mismatch between the nodes.
> What MTU are you using and how is your topology? If you want, you can 
> reply this in private!
>
> All the best
> Sten
>
>
>
> _______________________________________________
> pve-user mailing list
> pve-user at pve.proxmox.com
> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20150128/db5aa78f/attachment-0015.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3227 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20150128/db5aa78f/attachment-0015.bin>


More information about the pve-user mailing list