[PVE-User] implementing openvswitch

Sten Aus sten.aus at eenet.ee
Tue Jan 27 09:40:51 CET 2015


Hi

I have a problem when implementing Open vSwitch. When I configure my one 
node to use ovs, all cluster work is heavily disturbed - GUI lacks, 
commands take forever to reply.
As soon as I take proxmox interface down, everything normalizes.

Switches support multicast and IGMP snooping is turned off. Multicast 
ping (*ssmpingd* on one node and *asmping* on second node) works 
fluently on both directions.

*Should cluster work when all of the nodes are using Linux bridges and 
one is using ovs?* This node has been a cluster member and has used 
Linux bridges as well.

*On all nodes:*
- running kernel: 2.6.32-34-pve
- proxmox-ve-2.6.32: 3.3-139 (running kernel: 2.6.32-34-pve)
- pve-manager: 3.3-5 (running version: 3.3-5/bfebec03)

*On this node:*
openvswitch-switch:
   Installed: 2.3.0-1

*ovs-vsctl show* output
> *# ovs-vsctl show*
> dec7d5db-216b-42cf-bee7-60886d30c44e
>     Bridge "vmbr1234"
>         Port backnet
>             tag: 10
>             Interface backnet
>                 type: internal
>         Port "eth0"
>             Interface "eth0"
>         Port proxmox
>             tag: 15
>             Interface proxmox
>                 type: internal
>         Port "storage84"
>             tag: 84
>             Interface "storage84"
>                 type: internal
>         Port "storage88"
>             tag: 88
>             Interface "storage88"
>                 type: internal
>         Port "vmbr1234"
>             Interface "vmbr1234"
>                 type: internal
>     ovs_version: "2.3.0"
OVS is configured properly, at least I think so, because I have 
connectivity between hosts and I can ping and ssh between nodes, ISCSI 
connection is up and running.

Any directions or ideas are helpful!

Thanks!
Sten

On 21.01.15 15:53, Sten Aus wrote:
> Hi
>
> Will my cluster stay OK, if I implement openvswitch one by one for 
> each node?
>
> Node A is empty, I've migrated all VMs to other nodes and will install 
> openvswitch-switch and make config changes in /etc/network/interfaces, 
> but if I don't manage to do it for all nodes today, will everything be 
> okay and can I use this node?
>
> All of my switches are supporting multicast and it's turned on.
>
> Thanks!
>
>
>
> _______________________________________________
> pve-user mailing list
> pve-user at pve.proxmox.com
> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20150127/722a75ed/attachment-0015.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3227 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20150127/722a75ed/attachment-0015.bin>


More information about the pve-user mailing list