[PVE-User] Open vSwitch and Clustering

Brian Hart brianhart at ou.edu
Mon Jan 19 23:09:12 CET 2015


Alexandre,

Thank you for the suggestions - I'll give this a try with the switch
configuration.  We've got other proxmox clusters with several servers in
them we just hadn't tried the OVS setup yet.  Once these two nodes are
setup I plan to rebuild an existing cluster and add it with these two new
ones so I won't be leaving it as a two node setup for long.  Thanks for the
advice!

Brian



On Mon, Jan 19, 2015 at 1:01 AM, Alexandre DERUMIER <aderumier at odiso.com>
wrote:

> Hi,
>
> maybe it's multicast filtering related.
>
> OVS don't support igmp snooping (multicast filtering), and also don't
> support igmp querier.
>
> Linux bridge have igmp snooping enable by default and also igmp querier.
>
> to get igmp snooping, you need at least 1 igmp querier on your network.
> They are some elections when multicast igmp queriers are enabled.
>
>
> My best recommendation could be to have igmp querier enabled on your
> physical switch, to avoid problem.
>
>
> also, you really need to have 3 nodes minimum to have quorum for cluster
> services.
>
>
> ----- Mail original -----
> De: "Brian Hart" <brianhart at ou.edu>
> À: "proxmoxve" <pve-user at pve.proxmox.com>
> Envoyé: Vendredi 16 Janvier 2015 23:54:18
> Objet: [PVE-User] Open vSwitch and Clustering
>
> We got two new systems that we installed the latest version of proxmox on.
> Did an apt-get update and dist-upgrade to make sure they were on the most
> recent versions. We then created a cluster and got them talking and all
> that went fine.
>
> The problem came when we added OVS to one of the nodes and set it all up
> in the GUI. Once we did a reboot we have not been able to get the cluster
> communications to work since then. We have tried to revert it back
> completely - removing open vswitch packages and all and doing a stock
> config in the /etc/network/interfaces file but we cannot get multicast to
> work now between the two nodes. Nothing else changed.
>
> Has anybody else run across this or are there known issues with doing OVS
> and clustering? I've done a lot of google searching but have not found a
> clear answer or solution to a problem like this.
>
> Any help or advice is greatly appreciated!
>
> Thanks,
> Brian
>
>
> _______________________________________________
> pve-user mailing list
> pve-user at pve.proxmox.com
> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20150119/3c2e9e00/attachment-0015.html>


More information about the pve-user mailing list