[PVE-User] Intel X710 10Gbit network card

Sten Aus sten.aus at eenet.ee
Thu Apr 16 22:16:17 CEST 2015

I dont want to shout before the night, but it seems that the link is 

I have downgraded drivers to
> driver: i40e
> version: 1.1.23
As my coworker set up a new environment with Ubuntu and run different 
kvm's there and it worked, I saw that there was a difference between 
driver versions. Ubuntu was using
> driver: i40e
> version: 0.3.36-k 
So, somehow I thought that why not try to downgrade.

On 16.04.15 14:32, Sten Aus wrote:
> Got a little bit further
> Turned on stp for this vmbr and now VM gets traffic for about 10-15 
> seconds and then no packet flow again.
> Note that packets are going from VM to (for example) DHCP server, but 
> they will get lost on their way back. They will arrive at the eth5 and 
> vmbr, but not to tap, which is connected to the VM by qemu.
> Tried to upgrade Intel X710 firmware as well, no luck there. Not to 
> mention the drivers small upgrade which I already did yesterday.
> On 15.04.15 22:03, Sten Aus wrote:
>> Thanks for the tip, but this was not the case.
>> On 15.04.15 21:24, Michael Rasmussen wrote:
>>> On Wed, 15 Apr 2015 21:01:35 +0300
>>> Sten Aus <sten.aus at eenet.ee> wrote:
>>>>> What does tcpdump disclose running on host and in VM?
>>>>> On host tcpdump -i vmbr10
>>>> Coworker did a lot of tcpdumps during the day and it appears the VM 
>>>> tap device is not getting ARPs back. I mean this tap device what 
>>>> qemu brings up/makes.
>>> A long shot. Try to disable hardware checksum offload since it is know
>>> to cause problems in virtualized environments.
>>> You can try with ethtool before making permanent changes: ethtool -K
>>> eth5 tx off
>>> If that works you could add it permanently to udev:
>>> Create this file: /etc/udev/rules.d/81-bridge.rules
>>> With the following content:
>>> ACTION=="add", SUBSYSTEM=="net", NAME=="vmbr*", RUN+="/sbin/ethtool -K
>>> $env{INTERFACE} tx off"
>> _______________________________________________
>> pve-user mailing list
>> pve-user at pve.proxmox.com
>> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
> _______________________________________________
> pve-user mailing list
> pve-user at pve.proxmox.com
> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.proxmox.com/pipermail/pve-user/attachments/20150416/e4eb13c2/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3242 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://lists.proxmox.com/pipermail/pve-user/attachments/20150416/e4eb13c2/attachment.bin>

More information about the pve-user mailing list