[PVE-User] Two-factor auth

Gilberto Nunes gilberto.nunes32 at gmail.com
Mon Sep 15 15:05:04 CEST 2014


Oh... I figure out...
I fill Key ID's and now works as a charm!
Just a note: this is not in the how to...

Thanks

2014-09-15 10:00 GMT-03:00 Gilberto Nunes <gilberto.nunes32 at gmail.com>:

> Or, you meant do it in Key ID's field on Users configuration??
>
> 2014-09-15 9:59 GMT-03:00 Gilberto Nunes <gilberto.nunes32 at gmail.com>:
>
> Like this?
>>
>> 2. Add a unique secret (password) to each user - this secret has also to
>> be added to your OATH app on the smartphone of each user. To generate a
>> secret, you can run the following command on your Proxmox VE host:
>>
>>  oathkeygen
>>
>> If a user has more secrets, just add all your secrets separated with
>> spaces.
>>
>>
>> Yes... I do it with  oathkeygen... oauthjeygen <user>, oauthkeygen
>> <user>@pve... no effect...
>>
>> 2014-09-15 9:54 GMT-03:00 Dietmar Maurer <dietmar at proxmox.com>:
>>
>>  You added the secret key to the user?
>>>
>>>
>>>
>>> *From:* pve-user [mailto:pve-user-bounces at pve.proxmox.com] *On Behalf
>>> Of *Gilberto Nunes
>>> *Sent:* Montag, 15. September 2014 14:27
>>> *To:* pve-user at pve.proxmox.com
>>> *Subject:* Re: [PVE-User] Two-factor auth
>>>
>>>
>>>
>>> I get this error on syslog:
>>>
>>> Sep 15 09:25:16 pve01 pvedaemon[3138]: WARNING: Use of uninitialized
>>> value $keys in pattern match (m//) at /usr/share/perl5/PVE/AccessControl.pm
>>> line 1235.
>>> Sep 15 09:25:16 pve01 pvedaemon[3138]: authentication failure;
>>> rhost=192.168.1.101 user=gilberto at pve msg=oath auth failed
>>>
>>>
>>>
>>
>>
>>
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20140915/e01a1b7d/attachment-0015.html>


More information about the pve-user mailing list