[PVE-User] vzdump - broken pipes

Lindsay Mathieson lindsay.mathieson at gmail.com
Fri Nov 28 22:02:55 CET 2014


I get this all the time, its been a continual problem with proxmox. Every 
backup run has at least one, often many - it makes the backups useless.

I only run backups from one node at a tim, I've tried rate limiting, but it 
doesn't seem to make a difference. 

Destination is a NFS share on a QNAP 420 NAS,  1GB*2 LACP Bond. When I use an 
external USB drive it seems to work every time.


NFO: status: 19% (26060849152/136899993600), sparse 1% (2619174912), duration 
1016, 20/17 MB/s
INFO: status: 20% (27407548416/136899993600), sparse 2% (2919374848), duration 
1055, 34/26 MB/s
lzop: Input/output error: <stdout>
INFO: status: 20% (28006416384/136899993600), sparse 2% (2936569856), duration 
1076, 28/27 MB/s
ERROR: vma_queue_write: write error - Broken pipe
INFO: aborting backup job
ERROR: Backup of VM 401 failed - vma_queue_write: write error - Broken pipe


What can I do? what logs should I examine?

dmesg on the proxmox box doesn't seem to show anything.
dmesg on the nas has:

[190967.283021] nfsd: non-standard errno: -14
[304641.703023] nfsd: non-standard errno: -14

Which is interesting


thanks,
-- 
Lindsay
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part.
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20141129/bde0267b/attachment-0014.sig>


More information about the pve-user mailing list