[PVE-User] Two node plus Storage Cluster

Gilberto Nunes gilberto.nunes32 at gmail.com
Thu Mar 27 13:28:45 CET 2014


Hi again...

I mean, running a script when some host down...
Let make me clear...
I have two nodes: pve01 and pve02
I need run a script on pve01 when pve02 down...
I found some answer on google, like this:

<failoverdomains>
      <failoverdomain name="node1-domain" restricted="1">
	<failoverdomainnode name="node1.example.com"/>
      </failoverdomain>
      <failoverdomain name="node2-domain" restricted="1">
	<failoverdomainnode name="node2.example.com"/>
      </failoverdomain>
      <failoverdomain name="node3-domain" restricted="1">
	<failoverdomainnode name="node3.example.com"/>
      </failoverdomain>
    </failoverdomains>

    <resources>
      <!-- This script starts a qpidd broker acting as a backup. -->
      <script file="/etc/init.d/qpidd" name="qpidd"/>

      <!-- This script promotes the qpidd broker on this node to primary. -->
      <script file="/etc/init.d/qpidd-primary" name="qpidd-primary"/>

      <!-- This is a virtual IP address for client traffic. -->
      <ip address="20.0.20.200" monitor_link="1"/>
    </resources>

    <!-- There is a qpidd service on each node, it should be restarted
if it fails. -->
    <service name="node1-qpidd-service" domain="node1-domain"
recovery="restart">
      <script ref="qpidd"/>
    </service>
    <service name="node2-qpidd-service" domain="node2-domain"
recovery="restart">
      <script ref="qpidd"/>
    </service>
    <service name="node3-qpidd-service" domain="node3-domain"
recovery="restart">
      <script ref="qpidd"/>
    </service>

    <!-- There should always be a single qpidd-primary service, it can
run on any node. -->
    <service name="qpidd-primary-service" autostart="1" exclusive="0"
recovery="relocate">
      <script ref="qpidd-primary"/>
      <!-- The primary has the IP addresses for brokers and clients to
connect. -->
      <ip ref="20.0.20.200"/>
    </service>


But everytime I change the cluster.conf and try validate the file, the
validation go on 'till get a timeout or 'till I press Control + C...
After that, one node goes down... Even when I reboot the system, cman run
in Timeout error and /etc/pve is mounted as read-only...

I don't know if this happen because I'm using VirtualBox to test the system
or this is kind a bug...

Thanks


2014-03-27 9:19 GMT-03:00 Dietmar Maurer <dietmar at proxmox.com>:

> > I suppose that with resource and script I can define some script to run
> on
> > certain node... Is that right?
>
> If you want to run a script on a specific node you can simple setup and
> init script (no need for rgmanager).
>
>
>


-- 
Gilberto Ferreira
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20140327/576e0e79/attachment-0015.html>


More information about the pve-user mailing list