[PVE-User] Backup fail (low RAM)

Eneko Lacunza elacunza at binovo.es
Mon Jun 2 10:26:23 CEST 2014


Hi all,

This weekend just one backup out of about 34 failed in our proxmox cluster.

If I backup the affected VM now it continues to fail, both in snapshot 
and stop mode:

INFO: starting new backup job: vzdump 134 --remove 0 --mode stop 
--compress gzip --storage alamut-backups --node butroe
INFO: Starting Backup of VM 134 (qemu)
INFO: status = stopped
INFO: update VM 134: -lock backup
INFO: backup mode: stop
INFO: ionice priority: 7
INFO: creating archive 
'/mnt/pve/alamut-backups/dump/vzdump-qemu-134-2014_06_02-10_18_54.vma.gz'
INFO: starting kvm to execute backup task
Cannot set up guest memory 'pc.ram': Cannot allocate memory
ERROR: Backup of VM 134 failed - start failed: command '/usr/bin/kvm -id 
134 -chardev 
'socket,id=qmp,path=/var/run/qemu-server/134.qmp,server,nowait' -mon 
'chardev=qmp,mode=control' -vnc 
unix:/var/run/qemu-server/134.vnc,x509,password -pidfile 
/var/run/qemu-server/134.pid -daemonize -name sharepoint -smp 
'sockets=1,cores=1' -nodefaults -boot 'menu=on' -vga std -no-hpet -cpu 
'kvm64,hv_spinlocks=0xffff,hv_relaxed,+lahf_lm,+x2apic,+sep' -k es -m 
8192 -device 'piix3-usb-uhci,id=uhci,bus=pci.0,addr=0x1.0x2' -device 
'usb-tablet,id=tablet,bus=uhci.0,port=1' -device 
'virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3' -drive 
'file=/srv/storage-local/images/134/vm-134-disk-1.qcow2,if=none,id=drive-virtio0,format=qcow2,aio=native,cache=none' 
-device 
'virtio-blk-pci,drive=drive-virtio0,id=virtio0,bus=pci.0,addr=0xa,bootindex=100' 
-drive 
'file=/mnt/pve/alamut-backups/template/iso/SharePointServer_x64_en-us.iso,if=none,id=drive-ide0,media=cdrom,aio=native' 
-device 'ide-cd,bus=ide.0,unit=0,drive=drive-ide0,id=ide0,bootindex=200' 
-netdev 
'type=tap,id=net0,ifname=tap134i0,script=/var/lib/qemu-server/pve-bridge,vhost=on' 
-device 
'virtio-net-pci,mac=FE:92:3B:21:E9:C6,netdev=net0,bus=pci.0,addr=0x12,id=net0,bootindex=300' 
-rtc 'driftfix=slew,base=localtime' -global 
'kvm-pit.lost_tick_policy=discard' -S' failed: exit code 1
INFO: Backup job finished with errors
TASK ERROR: job errors

VM has 8 GB of RAM but hypervisor is low on RAM:
root at butroe:# free
              total       used       free     shared    buffers cached
Mem:      37056664   36834376     222288          0     154308 3816584
-/+ buffers/cache:   32863484    4193180
Swap:      4194296    1928464    2265832

The VM is stopped.

Is there a way to backup VMs without allocating their assigned RAM?

Cheers
Eneko

-- 
Zuzendari Teknikoa / Director T├ęcnico
Binovo IT Human Project, S.L.
Telf. 943575997
       943493611
Astigarraga bidea 2, planta 6 dcha., ofi. 3-2; 20180 Oiartzun (Gipuzkoa)
www.binovo.es




More information about the pve-user mailing list