[PVE-User] Cluster HA withtou Fence Device !

Yannis Milios yannis.milios at gmail.com
Mon Jul 7 11:50:50 CEST 2014


I tried the same config on a lab but does not work.
I think its not possible to have HA without proper fencing.
Im
On Jul 7, 2014 12:40 PM, "Angel Docampo" <adocampo at dltec.net> wrote:

>  What do you mean by "it works"?
> Without fence mechanism, the cluster won't be aware there a node down, and
> then you can continue writing modifications in both sides and finish with a
> split brain.
>
>
>
>  El 05/07/14 21:49, Gilberto Nunes escribió:
>
>   WOW
>
> Even with just 2 nodes HA works fine!!!!
>
>  I have tested some minutes ago...
>
>  Is there something improvement on HA Code??
>
>  I would like to know...
>
> Thanks
>
>
> 2014-07-05 16:37 GMT-03:00 Gilberto Nunes <gilberto.nunes32 at gmail.com>:
>
>>     Hi
>>
>>  Today I have deploy a tree node plus storage scenario in a lab.
>>  First at all, I image that I need configure fence device, as docs
>> demand...
>>  So, I decide to use a MAnaged Switch (DLikn DES-3028).
>>  But, I realize that even without fence configuratio HA works properly
>> and NICE, I might add..
>>
>>  Here's the configuration:
>>
>> <?xml version="1.0"?>
>> <cluster config_version="18" name="CLUSTER">
>>   <cman expected_votes="3"
>> keyfile="/var/lib/pve-cluster/corosync.authkey"/>
>>    <quorumd allow_kill="0" interval="3" label="quorum" tko="10" votes="1">
>>    <heuristic interval="3" program="ping 10.90.90.100 -c1 -w1" score="1"
>> tko="4"/>
>>    <heuristic interval="3" program="ip addr | grep eth0 | grep -q UP"
>> score="2" tko="3"/>
>>  </quorumd>
>>  <totem token="54000"/>
>>   <clusternodes>
>>     <clusternode name="pve01" nodeid="1" votes="1">
>>     </clusternode>
>>     <clusternode name="pve02" nodeid="2" votes="1">
>>     </clusternode>
>>     <clusternode name="pve03" nodeid="3" votes="1">
>>     </clusternode>
>>   </clusternodes>
>>   <rm>
>>    <failoverdomains>
>>      <failoverdomain name="serverfailover" ordered="1" restricted="0">
>>        <failoverdomainnode name="pve1" priority="1"/>
>>        <failoverdomainnode name="pve2" priority="2"/>
>>        <failoverdomainnode name="pve3" priority="3"/>
>>      </failoverdomain>
>>    </failoverdomains>
>>     <pvevm autostart="1" vmid="100"/>
>>   </rm>
>> </cluster>
>>
>>
>>  I always though that I need fence device in order to make HA work...
>>
>>  Thanks
>>
>> --
>> Gilberto Ferreira
>>
>
>
>
> --
> Gilberto Ferreira
>
>
> _______________________________________________
> pve-user mailing listpve-user at pve.proxmox.comhttp://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
>
>
> --
>
>
>
> *Angel Docampo *
> *Datalab Tecnologia, s.a.*
> Castillejos, 352 - 08025 Barcelona
> Tel. 93 476 69 14 - Ext: 706
> Mob. 670.299.381
>
> _______________________________________________
> pve-user mailing list
> pve-user at pve.proxmox.com
> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20140707/f136d71b/attachment-0015.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Logo-DLtec.png
Type: image/png
Size: 5898 bytes
Desc: not available
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20140707/f136d71b/attachment-0015.png>


More information about the pve-user mailing list