[PVE-User] Impossible to create two nodes cluster.

Angel Docampo adocampo at dltec.net
Mon Sep 30 11:51:59 CEST 2013

El 27/09/13 23:33, Ric Moore escribió:
> On 09/26/2013 09:26 AM, Angel Docampo wrote:
>> El 26/09/13 15:16, Luis G. Coralle escribió:
>>> I think they should be in same network.
>>> How is configured the other proxmox cluster?
>>> 2013/9/26 Angel Docampo <adocampo at dltec.net
>>> <mailto:adocampo at dltec.net>>
>>>     Everytime I need to create a cluster in proxmox I suffer a bit
>>>     PITA. But
>>>     now I simply can't do it. I've reinstalled several times and
>>>     deleted and
>>>     recreated the cluster again and again. No luck.
>>>     Multicast does not work in this network, so I used unicast.
>>> There are
>>>     another proxmox cluster in the same network and it's working (it
>>> was
>>>     very painfull also to install, but once I realized the problem was
>>>     unicast and the mtu size, it works very well, except when adding a
>>>     node,
>>>     that always is another pain).
>>>     So, I would like to explain how I'm doing this and perhaps I'm
>>> pretty
>>>     obfuscated to see what is happening.
>>>     I've installed two debian 7.1, LVM partitions (not necessary, but
>>>     I did
>>>     it anyway), and installed proxmox. The servers works as expected
>>>     separately.
>>>     The server p01 have the IP:
>>>     The server p02 have the IP:
>>>     The two networks are visible each other, and as cluster protocol
>>>     is udp,
>>>     it should work. Am I wrong?
>>>     Then on p01, I've created the cluster with "pvecm create
>>> testcluster",
>>>     it worked
>>>     I've copied /etc/pve/cluster.conf to /etc/pve/cluster.conf.new,
>>>     increased the version number and add transport="udpu" to the cman
>>>     section and added the section <totem netmtu="1400" /> (I tried
>>> without
>>>     it also). Then I've activated the new configuration throught the
>>> GUI.
>>>     I've double checked /etc/hosts to assure they resolve the names
>>>     through
>>>     this mechanism.
>>>     Then on p02 I tried to add the node with "pvecm add p01" (also
>>> tried
>>>     with IP and also tried this command from p01, both with hostname
>>>     and IP
>>>     of the p02 node).
>>>     root at p02:~# pvecm add p01
>>>     root at p01's
>>>     password:
>>>     copy corosync auth
>>>     key
>>>     stopping pve-cluster
>>>     service
>>>     Stopping pve cluster filesystem:
>>>     pve-cluster.
>>>     backup old
>>>     database
>>>     Starting pve cluster filesystem :
>>>     pve-cluster.
>>>     Starting
>>>     cluster:
>>>        Checking if cluster has been disabled at boot... [  OK
>>>     ]
>>>        Checking Network Manager... [  OK
>>>     ]
>>>        Global setup... [  OK
>>>     ]
>>>        Loading kernel modules... [  OK
>>>     ]
>>>        Mounting configfs... [  OK
>>>     ]
>>>        Starting cman... [  OK
>>>     ]
>>>        Waiting for quorum...
>>>     [FAILED]
>>>        Waiting for quorum...
> I had to issue, on the master, pvecm e 1
> to resolve the quorum error. Running like a charm now. That is in the
Thank you very much. It's not so easy, yet even /etc/pve now was
writeable, and cluster.conf was the same in each node, it still showed a
split brain situation.  But your advice gave me some direction to

I found that pvecm e 1 its the same than edit cluster.conf and add the
parameter "expected_votes=1" on directive cman. I also added the
parameters transport="udpu" (I have no multicast support) and
two_node="1" and rebooted the main node.

After that, I could add the second node and restart pve-cluster and cman
daemons on both nodes (or restart the machines) in order to see them

It has been pretty hard to made it work, but I think now I got the concepts.

Thank you very much.

Angel Docampo

More information about the pve-user mailing list